Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Markdown: Bad recognition of link end for some unicode chars #1947

Closed
BenWiederhake opened this issue Sep 6, 2018 · 1 comment

Comments

Projects
None yet
3 participants
@BenWiederhake
Copy link
Contributor

commented Sep 6, 2018

Minimal reproducing example:

This is displayed as normal text.
[ク](https://google.com)
This isn't.!

Steps to reproduce: Save it as foo.md, and open it in geany. Then delete the last exclamation mark to get around #971.

Expected behavior: Both normal text lines are displayed using the "normal text" style.

Actual behavior: The last line's style indicates that it is somehow still part of the link. Not visible in the short example: This affects the entire rest of the document.

Screenshot:
Screenshot of the faulty behavior

Note that even before this "remove the last exclamation mark" step, one can see faulty behavior. Specifically, the T is styled wrong.

@elextr elextr added the scintilla label Sep 6, 2018

@elextr

This comment has been minimized.

Copy link
Member

commented Sep 6, 2018

Highlighting is provided by the Scintilla editing widget Geany uses. Does the problem also occur with Scite (the Scintilla test editor)? If so best to file a bug on Scintilla, if not probably will get fixed during some Scintilla update.

Note still happens with Scintilla 3.10 PR so not fixed there.

b4n added a commit to b4n/geany that referenced this issue Jan 12, 2019

@b4n b4n closed this in #2045 Jan 13, 2019

@b4n b4n added this to the 1.35 milestone Jan 13, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.