Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
68 lines (67 sloc) 2.18 KB
{
"name": "geckos.io",
"description": "Real-time client/server communication over UDP using WebRTC and Node.js",
"version": "1.0.0",
"private": true,
"scripts": {
"lerna:ls": "lerna ls",
"lerna:diff": "lerna diff",
"lerna:changed": "lerna changed",
"lerna:version": "lerna version --no-changelog --no-push && cd packages/client && npm run bundle",
"build:common": "tsc --build packages/common/tsconfig.json",
"build:client": "tsc --build packages/client/tsconfig.json",
"build:server": "tsc --build packages/server/tsconfig.json",
"build": "npm run build:common && npm run build:client && npm run build:server",
"publish:common": "cd packages/common/ && npm publish",
"publish:server": "cd packages/server/ && npm publish",
"publish:client": "cd packages/client/ && npm publish",
"dev": "cd packages/chatApp && npm run dev",
"prettier": "prettier --write 'src/**/*.ts' && prettier --write 'dev/chatApp/**/*.ts'",
"postinstall": "lerna bootstrap --no-ci && npm run build",
"test": "npm run build-client-bundle && jest --forceExit",
"build-client-bundle": "webpack --config packages/client/webpack/webpack.prod.js --path=../../../test/.tmp --packageVersion=latest"
},
"keywords": [
"realtime",
"framework",
"webrtc",
"nodejs",
"udp",
"sctp",
"events",
"io"
],
"author": "Yannick Deubel (https://github.com/yandeu)",
"license": "BSD-3-Clause",
"repository": {
"type": "git",
"url": "git://github.com/geckosio/geckos.io.git"
},
"bugs": {
"url": "https://github.com/geckosio/geckos.io/issues"
},
"homepage": "http://geckos.io",
"directories": {
"lib": "lib"
},
"dependencies": {
"source-map-support": "^0.5.11"
},
"devDependencies": {
"copy-webpack-plugin": "^5.0.2",
"express": "^4.16.4",
"html-webpack-plugin": "^3.2.0",
"jest": "^24.7.1",
"jest-puppeteer": "^4.1.1",
"lerna": "^3.13.4",
"nodemon": "^1.18.11",
"npm-run-all": "^4.1.5",
"prettier": "^1.17.0",
"puppeteer": "^1.15.0",
"ts-loader": "^5.3.3",
"typescript": "^3.4.2",
"webpack": "^4.29.6",
"webpack-cli": "^3.3.0",
"webpack-node-externals": "^1.7.2"
}
}
You can’t perform that action at this time.