Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge branch 'master' of github.com:mde/geddy

  • Loading branch information...
commit d5c5054a1ce34477b652187b7f439b07ffe1524c 2 parents 65fc7bf + b1d1eb1
@larzconwell larzconwell authored
View
5 bin/cli.js
@@ -136,6 +136,7 @@ if (cmds.length) {
cmds[0] == 'secret' ||
cmds[0] == 'db:init' ||
cmds[0] == 'auth' ||
+ cmds[0] == 'auth:update' ||
cmds[0] == 'console')
&& !cmds[1]) {
throw new Error(cmds[0] + ' command requires another argument.');
@@ -176,6 +177,10 @@ if (cmds.length) {
// Create DBs
cmd += 'auth:init';
break;
+ case 'auth:update':
+ // Create DBs
+ cmd += 'auth:update';
+ break;
case 'db:init':
// Create DBs
cmd += 'db:init';
View
5 lib/sessions/stores/redis.js
@@ -33,7 +33,8 @@ Config section should look like this:
'server' is your Redis server.
*/
-var file = require('utilities').file
+var utils = require('utilities')
+ , file = utils.file
, RedisServer = file.requireLocal('redis');
var Redis = function (callback) {
@@ -55,7 +56,7 @@ Redis.prototype = new (function () {
_ns = geddy.config.sessions.server.ns || "";
_client = RedisServer.createClient(port, host, opts);
_client.on("error", function (err) {
- sys.error("Redis error " + _client.host + ":" + _client.port + " - " + err);
+ utils.log.error("Redis error " + _client.host + ":" + _client.port + " - " + err);
});
if (geddy.config.sessions.server.auth) {
View
2  package.json
@@ -36,4 +36,4 @@
"engines": {
"node": "*"
}
-}
+}
View
22 templates/Jakefile
@@ -739,6 +739,28 @@ namespace('gen', function () {
namespace('auth', function () {
+ task('update', {async: true}, function () {
+ // FIXME: Pull these version numbers out of geddy-passport's package.json
+ var cwd = process.cwd()
+ , packages = 'geddy-passport@0.0.x'
+ , updatePath = path.join('geddy-passport', 'app',
+ 'helpers', 'passport');
+
+ console.log('Updating helper from ' + packages + '...');
+ jake.exec('npm uninstall ' + packages +
+ ' && npm install ' + packages, function () {
+ var from = path.join(cwd, 'node_modules', updatePath)
+ , to = path.join(cwd, 'app', 'helpers');
+ jake.rmRf(path.join(to, 'passport'), {silent: true});
+ jake.cpR(from, to, {silent: true});
+ console.log('Updated helper from ' + packages);
+ console.log('Cleaning up...');
+ jake.exec('npm uninstall geddy-passport', function () {
+ complete();
+ });
+ }, {printStdout: true});
+ });
+
task('init', {async: true}, function () {
var go = false
// FIXME: Pull these version numbers out of geddy-passport's package.json
Please sign in to comment.
Something went wrong with that request. Please try again.