Skip to content
Compare
Choose a tag to compare

Breaking Changes

N/A

New/changed variables in default.config.yml

  • Added variable vagrant_nfs_fix_enabled: false - See #2154. If you are having trouble with NFS going away on macOS Big Sur, override this variable and set it to true to overcome a Vagrant bug in the latest version of macOS.

Improvements

  • Upgraded php-versions, solr, memcached, nginx, and mysql roles to latest versions.

Bugfixes

  • #2154: Add new vagrant-nfs-fix role to solve NFS issues on macOS Big Sur.
  • #2166: Fix ansible version output regex matching for new core/community version output.
Compare
Choose a tag to compare

Breaking Changes

N/A

New/changed variables in default.config.yml

  • Replaced obsolete variable php_opcache_enabled_in_ini with php_opcache_enable.

Improvements

  • #2109: Switch CI test environment from homegrown script and Travis CI to Molecule and GitHub Actions.
  • Updated Postgres role to latest version.
  • Updated Composer role to latest version to allow switching between Composer major versions.

Bugfixes

  • #2137: Use pip3 inside VM if using ansible_local provisioner.
  • #2144: Update docs for native synced folder usage due to changed typing of the variable in Vagrant.
  • #2121: Replace php_opcache_enabled_in_ini with php_opcache_enable.
  • Updated Drush role for better Composer v2 compatibility.
Compare
Choose a tag to compare

Breaking Changes

N/A

New/changed variables in default.config.yml

The hirak/prestissimo package was removed from composer_global_packages (and that variable is now empty).

Improvements

  • N/A

Bugfixes

  • #2100: Remove hirak/prestissimo, for Composer v2 compatibility.
  • #2095: Fix syntax errors in example drupal.composer.json file.
Compare
Choose a tag to compare

Breaking Changes

N/A

New/changed variables in default.config.yml

N/A

Improvements

  • #2083: Improve README guide for installing Drupal 8 instead of default Drupal 9.
  • Updated roles: security, nginx, mysql, php, php-mysql, solr, elasticsearch, repo-remi, composer.

Bugfixes

  • #2076: Fix bug when switching PHP versions to/from PHP 7.4.
Compare
Choose a tag to compare

Drupal VM 6 drops support for some older OS distributions, to increase stability under the latest versions of Ubuntu, CentOS, and Debian, and to finally drop all support for the now-unsupported Python 2.

The Drupal VM Docker container image is now based on Debian 10 Buster, though the default Drupal VM box when running as a VirtualBox VM is still based on Ubuntu 18.04.

The default PHP version is now PHP 7.4, which works great with all the latest versions of Drupal 7, 8, and 9.

Breaking Changes

  • #2065: Drop official support for Debian 9, CentOS 7, and Ubuntu 16.04 and Python 2.
  • #2061: Default to PHP 7.4.
  • Drupal VM Docker container now based on Debian 10 Buster.

New/changed variables in default.config.yml

  • Removed centos7, debian9, and ubuntu1604 from vagrant_box options.
  • ansible_python_interpreter now defaults to python3 (was /usr/bin/python3).
  • drupal_composer_dependencies now includes both "drush/drush:^10" and "drupal/devel:^4.0".
  • drupal_composer_project_package now defaults to the recommended Drupal project: "drupal/recommended-project:^9@dev".
  • drupal_major_version is now 9 (was 8).
  • php_version is now "7.4" (was "7.2").
  • Added php_xdebug_version: 2.9.5.

Improvements

  • #2050: Default to Drupal 9.
  • #1997: Include php_xdebug_version in default config for visibility.
  • Updated roles: varnish, solr, elasticsearch, java, memcached, postgresql, adminer, php, drupal.

Bugfixes

  • #2041: Point to Python 3 interpreter in $PATH.
  • #2062: Allow Composer to use more memory since it runs out at 1.5 GB.
  • #2063: Update Devel version to work with Drupal 9.
  • #2064: Explicitly require Drush on new sites to work with Drupal 9.
  • #2066: Fix postfix service failure on CentOS 8 test container.
  • #2059: Improve docs for Windows usage.
Compare
Choose a tag to compare

This release defaults to Python 3 for all Ansible-related tasks, which means some older OSes require a new variable to be overridden to work correctly. For most users, no change is required, however. The release also updates the order in which Postgresql updates

Breaking Changes

  • #2025: Ansible's Python interpreter now defaults to python3 (was using default which was python).
  • #2024: Postgresql database and user order of setup reversed, so users should not have 'db'/'priv' set, but database needs 'owner' set.
  • #2025: Minimum required Ansible version is now 2.8.
  • #2025: Minimum required Vagrant version is now 2.2.0.

New/changed variables in default.config.yml

  • ansible_python_interpreter: defaults to /usr/bin/python3, override to /usr/bin/python if using CentOS 7, Ubuntu 16.04, or Debian 9.
  • drupalvm_vagrant_version_min: was '1.8.6', now '2.2.0'.
  • drupalvm_ansible_version_min: was '2.5', now '2.8'.
  • postgresql_databases: added owner parameter, set to "{{ drupal_db_user }}"
  • postgresql_users: removed db and priv parameters.
  • solr_version: was "5.5.5", now "7.7.2".
  • java_packages: new variable, set to openjdk-8-jdk for Debian/Ubuntu, java-1.8.0-openjdk for RHEL/CentOS.

Improvements

  • #1960: Use latest Solr 7.x version for better install experience.
  • #2025: Use Python 3 for Ansible on all the latest OSes.
  • Updated roles: php-pecl, postgresql, php, mysql.

Bugfixes

  • #2024: Fix chicken-and-egg ordering of postgresql database and user ownership.
  • #1675: Get CI tests for Postgresql working again.
Compare
Choose a tag to compare

Breaking Changes

New/changed variables in default.config.yml

N/A

Improvements

  • Improved CentOS 8 compatibility.
  • Updated roles: drupal, php-xdebug, php-xhprof, php-versions, java, security, nodejs, elasticsearch, firewall, varnish, blackfire, daemonize, mysql, postgresql, ruby, php-pecl
Compare
Choose a tag to compare

This release adds support for PHP 7.4, and completely drops PHP 5.6 support (in the past, brave and daring souls could attempt to run 5.6—it is almost impossible to do so in Drupal VM as of this release).

Breaking Changes

  • #1987: Minimum required Ansible version is now 2.5.
  • #1993: Dropped support for old unsupported PHP versions: 5.6, 7.0, 7.1.

New/changed variables in default.config.yml

  • drupalvm_ansible_version_min: '2.5' (was '2.4')
  • php_version supports "7.2", "7.3", or "7.4" (5.6, 7.0, and 7.1 dropped)

Improvements

  • #1993: Add PHP 7.4 support. Drop 5.6, 7.0, and 7.1 support.
  • Updated roles: mailhog, postgresql, php-versions.
  • Update config.yml documentation to use modern PHP version.
Compare
Choose a tag to compare

Breaking Changes

N/A

New/changed variables in default.config.yml

N/A

Improvements

  • #1982: Updated Dashboard to Boostrap 4 for improved accessibility.
  • Updated various roles to ensure Ansible 2.9 compatibility.
  • Tested Drupal VM on macOS Catalina with latest versions of Vagrant and VirtualBox.
  • Updated roles: postgresql, firewall, git, php-versions, varnish

Bugfixes

  • #1969: Documentation typo fix for Linux installation.
  • #1973: Fix site-install error in certain circumstances.
Compare
Choose a tag to compare

Breaking Changes

N/A

New/changed variables in default.config.yml

N/A

Improvements

  • #1943: Update drupal console remote site example.
  • Updated roles: php-versions, nginx, composer, postgresql, apache, git, mysql, solr, drupal.

Bugfixes

  • #1920: Update git sandbox URL for pareview script.
  • #1953: Fix typo in Linux installation guide.
  • #1963, #1903, #1962, #1964: Fix PHP version mismatch when switching versions from 7.2 to 7.1.