Skip to content

@geerlingguy geerlingguy released this Apr 9, 2019 · 4 commits to master since this release

There are no major architectural changes in this release, which speaks to the current maturity of the Drupal VM platform; instead, this release focuses on updating all the default versions—most especially of the base OS to Ubuntu 18.04 'Bionic'. If you need to remain on Ubuntu 16.04 for now, please make sure you explicitly set vagrant_box: geerlingguy/ubuntu1604 in your config.yml, or use a version of the geerlingguy/drupal-vm Vagrant box older than 2.0.0.

Breaking Changes

  • #1881: Ubuntu 18.04 is now the default OS version (and is used in the geerlingguy/drupal-vm base image 2.0.0 and later)
    • Ubuntu 14.04 is no longer supported.
  • #1874: PHP 7.2 is now the default PHP version
    • PHP 5.6 is no longer supported (though you may be able to install it for some time).
  • #1885: Node.js 10.x is now the default Node.js version.
    • Node.js 0.10, 0.12, 4.x, and 5.x are no longer supported (though you may be able to install some of them for some time).

New/changed variables in default.config.yml

  • php_version changed from 7.1 to 7.2
  • nodejs_version changed from 6.x to 10.x

Improvements

  • #1919: Ran out of songs from original Tron soundtrack; releases shall now be named after Tron: Legacy tracks.

Bugfixes

  • #1895: Fixed typo in Drush docs.
Assets 2
You can’t perform that action at this time.