Skip to content
Permalink
Browse files

jruby/jruby#5907 has been released

I think it seems fine to require a current JRuby.
  • Loading branch information
matthewd committed Mar 21, 2020
1 parent 8890dbe commit 8b2cf42de0cdd27a392f6c469703b7d34e243aa3
Showing with 1 addition and 2 deletions.
  1. +0 −1 lib/gel/gemspec_parser.rb
  2. +1 −1 lib/gel/runtime.rb
@@ -66,7 +66,6 @@ def self.parse(content, filename, lineno = 1, root: File.dirname(filename), isol
"RUBYOPT" => "",
"GEL_GEMFILE" => "",
"GEL_LOCKFILE" => "",
"GEL_DISABLED" => "1", # https://github.com/jruby/jruby/pull/5907
},
RbConfig.ruby,
"-r", File.expand_path("compatibility", __dir__),
@@ -22,6 +22,6 @@

Gel::Environment.open(Gel::LockedStore.new(store))

if ENV["GEL_LOCKFILE"] && ENV["GEL_LOCKFILE"] != "" && !ENV["GEL_DISABLED"]
if ENV["GEL_LOCKFILE"] && ENV["GEL_LOCKFILE"] != ""
Gel::Environment.activate(output: $stderr)
end

0 comments on commit 8b2cf42

Please sign in to comment.
You can’t perform that action at this time.