Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Get in sync with latest JRuby #106

Merged
merged 2 commits into from Mar 21, 2020
Merged

Get in sync with latest JRuby #106

merged 2 commits into from Mar 21, 2020

Conversation

@matthewd
Copy link
Member

matthewd commented Mar 21, 2020

The conditionvariable bug we were avoiding in CI is fixed, as is the problem with overriding existing environment variables in spawn.

So we can return CI to running the latest, and we can drop the ugly GEL_DISABLED workaround.

In the long term we should support a wider range of JRuby versions, but for now, I think it's fine to [silently] require a quite recent release.

matthewd added 2 commits Mar 21, 2020
I think it seems fine to require a current JRuby.
@matthewd matthewd merged commit 8c5e7a9 into master Mar 21, 2020
1 check passed
1 check passed
buildkite/gel Build #297 passed (6 minutes)
Details
@matthewd matthewd deleted the latest-jruby branch Mar 21, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

1 participant
You can’t perform that action at this time.