Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fix error messages with "cabal update" -> "hackport update" Same fix …

…as marty.rosenberg@gmail.com once did for cabal-install-0.8.2, which we now are replacing.
  • Loading branch information...
commit 67ff6d8ed26fe240db1713fdcace98c42388ecf0 1 parent c66e34e
@kolmodin kolmodin authored trofi committed
View
6 cabal-install/Distribution/Client/IndexUtils.hs
@@ -204,7 +204,7 @@ readRepoIndex verbosity repo mode =
case repoKind repo of
Left remoteRepo -> warn verbosity $
"The package list for '" ++ remoteRepoName remoteRepo
- ++ "' does not exist. Run 'cabal update' to download it."
+ ++ "' does not exist. Run 'hackport update' to download it."
Right _localRepo -> warn verbosity $
"The package list for the local repo '" ++ repoLocalDir repo
++ "' is missing. The repo is invalid."
@@ -218,7 +218,7 @@ readRepoIndex verbosity repo mode =
Left remoteRepo -> warn verbosity $
"The package list for '" ++ remoteRepoName remoteRepo
++ "' is " ++ show dt ++ " days old.\nRun "
- ++ "'cabal update' to get the latest list of available packages."
+ ++ "'hackport update' to get the latest list of available packages."
Right _localRepo -> return ()
-- | It is not necessary to call this, as the cache will be updated when the
@@ -492,7 +492,7 @@ packageIndexFromCache mkPkg hnd entrs mode = accum mempty [] entrs
interror msg = die $ "internal error when reading package index: " ++ msg
++ "The package index or index cache is probably "
- ++ "corrupt. Running cabal update might fix it."
+ ++ "corrupt. Running 'hackport update' might fix it."
------------------------------------------------------------------------
-- Index cache data structure
View
2  cabal-install/Distribution/Client/Targets.hs
@@ -596,7 +596,7 @@ reportPackageTargetProblems verbosity problems = do
pkgs -> die $ unlines
[ "There is no package named '" ++ display name ++ "'. "
| name <- pkgs ]
- ++ "You may need to run 'cabal update' to get the latest "
+ ++ "You may need to run 'hackport update' to get the latest "
++ "list of available packages."
case [ (pkg, matches) | PackageNameAmbigious pkg matches _ <- problems ] of
Please sign in to comment.
Something went wrong with that request. Please try again.