Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
647 lines (574 sloc) 20.1 KB
<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="generator" content="Docutils 0.4: http://docutils.sourceforge.net/" />
<title>Packages failing with GHC 6.6</title>
<meta name="authors" content="Lennart Kolmodin &lt;kolmodin&#64;gentoo.org&gt; Duncan Coutts &lt;dcoutts&#64;gentoo.org&gt; Gentoo Haskell Herd &lt;haskell&#64;gentoo.org&gt;" />
<style type="text/css">
/*
:Author: David Goodger
:Contact: goodger@users.sourceforge.net
:Date: $Date: 2005-12-18 01:56:14 +0100 (Sun, 18 Dec 2005) $
:Revision: $Revision: 4224 $
:Copyright: This stylesheet has been placed in the public domain.
Default cascading style sheet for the HTML output of Docutils.
See http://docutils.sf.net/docs/howto/html-stylesheets.html for how to
customize this style sheet.
*/
/* used to remove borders from tables and images */
.borderless, table.borderless td, table.borderless th {
border: 0 }
table.borderless td, table.borderless th {
/* Override padding for "table.docutils td" with "! important".
The right padding separates the table cells. */
padding: 0 0.5em 0 0 ! important }
.first {
/* Override more specific margin styles with "! important". */
margin-top: 0 ! important }
.last, .with-subtitle {
margin-bottom: 0 ! important }
.hidden {
display: none }
a.toc-backref {
text-decoration: none ;
color: black }
blockquote.epigraph {
margin: 2em 5em ; }
dl.docutils dd {
margin-bottom: 0.5em }
/* Uncomment (and remove this text!) to get bold-faced definition list terms
dl.docutils dt {
font-weight: bold }
*/
div.abstract {
margin: 2em 5em }
div.abstract p.topic-title {
font-weight: bold ;
text-align: center }
div.admonition, div.attention, div.caution, div.danger, div.error,
div.hint, div.important, div.note, div.tip, div.warning {
margin: 2em ;
border: medium outset ;
padding: 1em }
div.admonition p.admonition-title, div.hint p.admonition-title,
div.important p.admonition-title, div.note p.admonition-title,
div.tip p.admonition-title {
font-weight: bold ;
font-family: sans-serif }
div.attention p.admonition-title, div.caution p.admonition-title,
div.danger p.admonition-title, div.error p.admonition-title,
div.warning p.admonition-title {
color: red ;
font-weight: bold ;
font-family: sans-serif }
/* Uncomment (and remove this text!) to get reduced vertical space in
compound paragraphs.
div.compound .compound-first, div.compound .compound-middle {
margin-bottom: 0.5em }
div.compound .compound-last, div.compound .compound-middle {
margin-top: 0.5em }
*/
div.dedication {
margin: 2em 5em ;
text-align: center ;
font-style: italic }
div.dedication p.topic-title {
font-weight: bold ;
font-style: normal }
div.figure {
margin-left: 2em ;
margin-right: 2em }
div.footer, div.header {
clear: both;
font-size: smaller }
div.line-block {
display: block ;
margin-top: 1em ;
margin-bottom: 1em }
div.line-block div.line-block {
margin-top: 0 ;
margin-bottom: 0 ;
margin-left: 1.5em }
div.sidebar {
margin-left: 1em ;
border: medium outset ;
padding: 1em ;
background-color: #ffffee ;
width: 40% ;
float: right ;
clear: right }
div.sidebar p.rubric {
font-family: sans-serif ;
font-size: medium }
div.system-messages {
margin: 5em }
div.system-messages h1 {
color: red }
div.system-message {
border: medium outset ;
padding: 1em }
div.system-message p.system-message-title {
color: red ;
font-weight: bold }
div.topic {
margin: 2em }
h1.section-subtitle, h2.section-subtitle, h3.section-subtitle,
h4.section-subtitle, h5.section-subtitle, h6.section-subtitle {
margin-top: 0.4em }
h1.title {
text-align: center }
h2.subtitle {
text-align: center }
hr.docutils {
width: 75% }
img.align-left {
clear: left }
img.align-right {
clear: right }
ol.simple, ul.simple {
margin-bottom: 1em }
ol.arabic {
list-style: decimal }
ol.loweralpha {
list-style: lower-alpha }
ol.upperalpha {
list-style: upper-alpha }
ol.lowerroman {
list-style: lower-roman }
ol.upperroman {
list-style: upper-roman }
p.attribution {
text-align: right ;
margin-left: 50% }
p.caption {
font-style: italic }
p.credits {
font-style: italic ;
font-size: smaller }
p.label {
white-space: nowrap }
p.rubric {
font-weight: bold ;
font-size: larger ;
color: maroon ;
text-align: center }
p.sidebar-title {
font-family: sans-serif ;
font-weight: bold ;
font-size: larger }
p.sidebar-subtitle {
font-family: sans-serif ;
font-weight: bold }
p.topic-title {
font-weight: bold }
pre.address {
margin-bottom: 0 ;
margin-top: 0 ;
font-family: serif ;
font-size: 100% }
pre.literal-block, pre.doctest-block {
margin-left: 2em ;
margin-right: 2em ;
background-color: #eeeeee }
span.classifier {
font-family: sans-serif ;
font-style: oblique }
span.classifier-delimiter {
font-family: sans-serif ;
font-weight: bold }
span.interpreted {
font-family: sans-serif }
span.option {
white-space: nowrap }
span.pre {
white-space: pre }
span.problematic {
color: red }
span.section-subtitle {
/* font-size relative to parent (h1..h6 element) */
font-size: 80% }
table.citation {
border-left: solid 1px gray;
margin-left: 1px }
table.docinfo {
margin: 2em 4em }
table.docutils {
margin-top: 0.5em ;
margin-bottom: 0.5em }
table.footnote {
border-left: solid 1px black;
margin-left: 1px }
table.docutils td, table.docutils th,
table.docinfo td, table.docinfo th {
padding-left: 0.5em ;
padding-right: 0.5em ;
vertical-align: top }
table.docutils th.field-name, table.docinfo th.docinfo-name {
font-weight: bold ;
text-align: left ;
white-space: nowrap ;
padding-left: 0 }
h1 tt.docutils, h2 tt.docutils, h3 tt.docutils,
h4 tt.docutils, h5 tt.docutils, h6 tt.docutils {
font-size: 100% }
tt.docutils {
background-color: #eeeeee }
ul.auto-toc {
list-style-type: none }
</style>
</head>
<body>
<div class="document" id="packages-failing-with-ghc-6-6">
<h1 class="title">Packages failing with GHC 6.6</h1>
<table class="docinfo" frame="void" rules="none">
<col class="docinfo-name" />
<col class="docinfo-content" />
<tbody valign="top">
<tr><th class="docinfo-name">Authors:</th>
<td>Lennart Kolmodin &lt;kolmodin&#64;gentoo.org&gt;
<br />Duncan Coutts &lt;dcoutts&#64;gentoo.org&gt;
<br />Gentoo Haskell Herd &lt;haskell&#64;gentoo.org&gt;</td></tr>
<tr class="field"><th class="docinfo-name">Updated:</th><td class="field-body">2006-10-12</td>
</tr>
</tbody>
</table>
<div class="section">
<h1><a id="failed-packages" name="failed-packages">Failed packages</a></h1>
<p>These are packages currently in portage cvs. Those are the ones we care
about when it comes to this round of ghc-6.6 compatabilty testing.</p>
<p>So make sure you're not using the overlay when you're testing these packages.
For example use:</p>
<pre class="literal-block">
PORTDIR_OVERLAY=&quot;&quot; emerge -pv dev-haskell/foo
</pre>
<p>Only the first error message is reported, as it is all I can see without
actually fixing anything :)</p>
<p>Packages We've used if not anything else mentioned:</p>
<ul class="simple">
<li>GHC 6.6</li>
<li>haddock-0.8</li>
<li>cabal-1.1.6 with unlit patch</li>
</ul>
<p>Note that we're listing all the versions for each package, however it's
only necessary to test the latest version with ghc-6.6. We can make previous
versions just block on gh-6.6.</p>
<p>Of course if we can't patch the latest version to work with ghc-6.6 then we
can just make it block on ghc-6.6 too <em>cough</em> wxhaskell <em>cough</em>.</p>
<div class="section">
<h2><a id="dev-haskell-buddha-1-2" name="dev-haskell-buddha-1-2">dev-haskell/buddha-1.2</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-buddha-1-2-r1" name="dev-haskell-buddha-1-2-r1">dev-haskell/buddha-1.2-r1</a></h2>
<p>dcoutts messed up the patch, but that's now fixed in cvs.</p>
<p>missing dep on dev-haskell/haskell-src, other than that it builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-alex-2-0-1" name="dev-haskell-alex-2-0-1">dev-haskell/alex-2.0.1</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-c2hs-0-13-4" name="dev-haskell-c2hs-0-13-4">dev-haskell/c2hs-0.13.4</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-c2hs-0-14-5" name="dev-haskell-c2hs-0-14-5">dev-haskell/c2hs-0.14.5</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-cabal-1-1-3-r1" name="dev-haskell-cabal-1-1-3-r1">dev-haskell/cabal-1.1.3-r1</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-cabal-1-1-4" name="dev-haskell-cabal-1-1-4">dev-haskell/cabal-1.1.4</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
<p>This will be ok as we'll have cabal-1.1.6 in the tree shortly.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-cpphs-1-1" name="dev-haskell-cpphs-1-1">dev-haskell/cpphs-1.1</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-cpphs-1-2" name="dev-haskell-cpphs-1-2">dev-haskell/cpphs-1.2</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-drift-2-1-2" name="dev-haskell-drift-2-1-2">dev-haskell/drift-2.1.2</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-drift-2-2-0" name="dev-haskell-drift-2-2-0">dev-haskell/drift-2.2.0</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-frown-0-6-1-r1" name="dev-haskell-frown-0-6-1-r1">dev-haskell/frown-0.6.1-r1</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-gtk2hs-0-9-10" name="dev-haskell-gtk2hs-0-9-10">dev-haskell/gtk2hs-0.9.10</a></h2>
</div>
<div class="section">
<h2><a id="dev-haskell-gtk2hs-0-9-9" name="dev-haskell-gtk2hs-0-9-9">dev-haskell/gtk2hs-0.9.9</a></h2>
</div>
<div class="section">
<h2><a id="dev-haskell-gtk2hs-0-9-10-r1" name="dev-haskell-gtk2hs-0-9-10-r1">dev-haskell/gtk2hs-0.9.10-r1</a></h2>
<p>fails with:</p>
<pre class="literal-block">
tools/c2hs/base/general/Binary.hs:59:7:
Could not find module `Data.FiniteMap':
Use -v to see a list of the files searched for.
make[1]: *** Deleting file `tools/c2hs/c2hsLocal.deps'
/usr/bin/ghc +RTS -RTS -c glib/System/Glib.hs -o glib/System/Glib.o -O -fffi -ignore-package glib -iglib -package-name glib '-#include&lt;glib-object.h&gt;' -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
glib/System/Glib.hs:12:0:
Failed to load interface for `System.Glib.UTFString':
Use -v to see a list of the files searched for.
</pre>
</div>
<div class="section">
<h2><a id="dev-haskell-haddock-0-7" name="dev-haskell-haddock-0-7">dev-haskell/haddock-0.7</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-haddock-0-8" name="dev-haskell-haddock-0-8">dev-haskell/haddock-0.8</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-happy-1-15" name="dev-haskell-happy-1-15">dev-haskell/happy-1.15</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-harp-0-2" name="dev-haskell-harp-0-2">dev-haskell/harp-0.2</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-haskell-src-exts-0-2" name="dev-haskell-haskell-src-exts-0-2">dev-haskell/haskell-src-exts-0.2</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-haxml-1-12" name="dev-haskell-haxml-1-12">dev-haskell/haxml-1.12</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
<p>committed to cvs</p>
</div>
<div class="section">
<h2><a id="dev-haskell-haxml-1-13-r1" name="dev-haskell-haxml-1-13-r1">dev-haskell/haxml-1.13-r1</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
<p>committed to cvs</p>
</div>
<div class="section">
<h2><a id="dev-haskell-haxml-1-13-2" name="dev-haskell-haxml-1-13-2">dev-haskell/haxml-1.13.2</a></h2>
<p>builds fine</p>
<p>committed to cvs</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hdbc-1-0-0" name="dev-haskell-hdbc-1-0-0">dev-haskell/hdbc-1.0.0</a></h2>
<p>needs mtl but builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hdbc-odbc-1-0-0-0" name="dev-haskell-hdbc-odbc-1-0-0-0">dev-haskell/hdbc-odbc-1.0.0.0</a></h2>
<p>needs mtl, fails with:</p>
<pre class="literal-block">
dist/build/tmp/Database/HDBC/ODBC/Connection.hs:&quot;Database/HDBC/ODBC/Connection.hsc&quot;: 77:43: Parse error
</pre>
</div>
<div class="section">
<h2><a id="dev-haskell-hdbc-postgresql-1-0-0-0" name="dev-haskell-hdbc-postgresql-1-0-0-0">dev-haskell/hdbc-postgresql-1.0.0.0</a></h2>
<p>needs mtl, builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hdbc-sqlite-1-0-0-0" name="dev-haskell-hdbc-sqlite-1-0-0-0">dev-haskell/hdbc-sqlite-1.0.0.0</a></h2>
<p>needs mtl, builds fine without doc, haddock fails with:</p>
<pre class="literal-block">
dist/build/tmp/Database/HDBC/Sqlite3/Statement.hs:&quot;Database/HDBC/Sqlite3/Statement.hsc&quot;: 46:15: parse error in doc string: [haddock: EOF token
</pre>
</div>
<div class="section">
<h2><a id="dev-haskell-hdoc-0-8-3" name="dev-haskell-hdoc-0-8-3">dev-haskell/hdoc-0.8.3</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hmake-3-10" name="dev-haskell-hmake-3-10">dev-haskell/hmake-3.10</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hmake-3-11" name="dev-haskell-hmake-3-11">dev-haskell/hmake-3.11</a></h2>
<p>builds fine (version 3.11)</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hs-plugins-0-9-10-r1" name="dev-haskell-hs-plugins-0-9-10-r1">dev-haskell/hs-plugins-0.9.10-r1</a></h2>
<p>blocked by &gt;=ghc-6.6</p>
<p>committed to cvs</p>
<p>fails with:</p>
<pre class="literal-block">
System/Plugins/LoadTypes.hs:31:0:
Bad interface file: /var/tmp/portage/hs-plugins-0.9.10-r1/work/hs-plugins-0.9.10/src/hi/Language/Hi/Parser.hi
Something is amiss; requested module hi-0.9.10:Language.Hi.Parser differs from name found in the interface file hi:Language.Hi.Parser
</pre>
</div>
<div class="section">
<h2><a id="dev-haskell-hs-plugins-0-9-6" name="dev-haskell-hs-plugins-0-9-6">dev-haskell/hs-plugins-0.9.6</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hs-plugins-0-9-8" name="dev-haskell-hs-plugins-0-9-8">dev-haskell/hs-plugins-0.9.8</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hs-plugins-1-0-rc0" name="dev-haskell-hs-plugins-1-0-rc0">dev-haskell/hs-plugins-1.0_rc0</a></h2>
<p>blocked by &gt;=ghc-6.6
builds fine, although it doesn't work</p>
<p>committed to cvs</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsql-1-7" name="dev-haskell-hsql-1-7">dev-haskell/hsql-1.7</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsql-mysql-1-7" name="dev-haskell-hsql-mysql-1-7">dev-haskell/hsql-mysql-1.7</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsql-odbc-1-7" name="dev-haskell-hsql-odbc-1-7">dev-haskell/hsql-odbc-1.7</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsql-postgresql-1-7" name="dev-haskell-hsql-postgresql-1-7">dev-haskell/hsql-postgresql-1.7</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsql-sqlite-1-7" name="dev-haskell-hsql-sqlite-1-7">dev-haskell/hsql-sqlite-1.7</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsshellscript-2-2-2" name="dev-haskell-hsshellscript-2-2-2">dev-haskell/hsshellscript-2.2.2</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsshellscript-2-3-0" name="dev-haskell-hsshellscript-2-3-0">dev-haskell/hsshellscript-2.3.0</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsshellscript-2-6-0" name="dev-haskell-hsshellscript-2-6-0">dev-haskell/hsshellscript-2.6.0</a></h2>
<p>works.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hsshellscript-2-6-3" name="dev-haskell-hsshellscript-2-6-3">dev-haskell/hsshellscript-2.6.3</a></h2>
<p>fails, needs package &quot;lang&quot;.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-http-2006-7-7" name="dev-haskell-http-2006-7-7">dev-haskell/http-2006.7.7</a></h2>
<p>works.</p>
<p>missing dep on:</p>
<ul class="simple">
<li>dev-haskell/network</li>
<li>dev-haskell/mtl</li>
</ul>
<p>other than that it builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hxt-4-02" name="dev-haskell-hxt-4-02">dev-haskell/hxt-4.02</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hxt-4-02-r1" name="dev-haskell-hxt-4-02-r1">dev-haskell/hxt-4.02-r1</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hxt-5-00" name="dev-haskell-hxt-5-00">dev-haskell/hxt-5.00</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-hxt-6-0" name="dev-haskell-hxt-6-0">dev-haskell/hxt-6.0</a></h2>
<p>missing dep on:</p>
<ul class="simple">
<li>dev-haskell/network</li>
<li>dev-haskell/hunit</li>
</ul>
<p>but otherwise builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-lhs2tex-1-10-pre" name="dev-haskell-lhs2tex-1-10-pre">dev-haskell/lhs2tex-1.10_pre</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-lhs2tex-1-11" name="dev-haskell-lhs2tex-1-11">dev-haskell/lhs2tex-1.11</a></h2>
<p>blocked by &gt;=ghc-6.6.</p>
<p>This should be solved by a new lhs2tex-1.12 release.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-missingh-0-14-4" name="dev-haskell-missingh-0-14-4">dev-haskell/missingh-0.14.4</a></h2>
<p>missing dep on:</p>
<ul class="simple">
<li>dev-haskell/network</li>
<li>dev-haskell/mtl</li>
<li>dev-haskell/haskell-src</li>
<li>dev-haskell/hunit</li>
</ul>
<p>fails with:</p>
<pre class="literal-block">
MissingH/Str.hs:47:7:
Could not find module `Text.Regex':
it is a member of package regex-compat-0.71, which is hidden
</pre>
<p>in other words, it's missing a dep on the regex-compat package
though this only exists as of ghc-6.6 so will need conditional patching.
<em>sigh</em>.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-uuagc-0-9-1" name="dev-haskell-uuagc-0-9-1">dev-haskell/uuagc-0.9.1</a></h2>
<p>builds fine</p>
</div>
<div class="section">
<h2><a id="dev-haskell-uulib-0-9-2" name="dev-haskell-uulib-0-9-2">dev-haskell/uulib-0.9.2</a></h2>
<p>I stand corrected, it works.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-wash-2-0-6" name="dev-haskell-wash-2-0-6">dev-haskell/wash-2.0.6</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-wash-2-3-1" name="dev-haskell-wash-2-3-1">dev-haskell/wash-2.3.1</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-wash-2-5-6" name="dev-haskell-wash-2-5-6">dev-haskell/wash-2.5.6</a></h2>
<p>builds fine.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-wxhaskell-0-8-r1" name="dev-haskell-wxhaskell-0-8-r1">dev-haskell/wxhaskell-0.8-r1</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-wxhaskell-0-9" name="dev-haskell-wxhaskell-0-9">dev-haskell/wxhaskell-0.9</a></h2>
<p>blocked by &gt;=ghc-6.4.</p>
</div>
<div class="section">
<h2><a id="dev-haskell-wxhaskell-0-9-4" name="dev-haskell-wxhaskell-0-9-4">dev-haskell/wxhaskell-0.9.4</a></h2>
<pre class="literal-block">
wx/src/Graphics/UI/WX/Types.hs:94:0:
Bad interface file: out/wx/imports/Graphics/UI/WXCore/Types.hi
Something is amiss; requested module wx:Graphics.UI.WXCore.Types differs from name found in the interface file wxcore:Graphics.UI.WXCore.Types
</pre>
<p>This is a hard one to fix.</p>
</div>
<div class="section">
<h2><a id="dev-util-bnfc-2-1-2" name="dev-util-bnfc-2-1-2">dev-util/bnfc-2.1.2</a></h2>
<ul class="simple">
<li>blocked &gt;=ghc-6.6</li>
<li>committed to cvs</li>
</ul>
</div>
<div class="section">
<h2><a id="dev-util-bnfc-2-2" name="dev-util-bnfc-2-2">dev-util/bnfc-2.2</a></h2>
<ul class="simple">
<li>patched to work with ghc-6.6</li>
<li>tested to work with ghc-6.4 too</li>
<li>committed to cvs</li>
</ul>
<!-- vim: tw=76 ts=2 : -->
</div>
</div>
</div>
</body>
</html>
Something went wrong with that request. Please try again.