Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

dev-haskell/chart-cairo: bump up to 1.2

Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
  • Loading branch information...
commit 3be8b2ac5c139a365a82b53bdb0d0bf238f04bc9 1 parent ddb89e7
@trofi trofi authored
View
1  dev-haskell/chart-cairo/Manifest
@@ -1 +1,2 @@
DIST Chart-cairo-1.1.tar.gz 4752 SHA256 abba911c048b58414c65e6cc634f968da5e18efe6188f1805ac5de811a8fa85e SHA512 3c9da51f4fb3d8d991f239f9e7309946c0cf45f89166d5def85ebc5c792ecd38efd22348a6cbb882bae56e6349a0ada0870635bbce9eab1fa0688f2baaee2964 WHIRLPOOL 1fb3d97c0153def65aa655a1933783ea7789f1cb39c123d582042a916f708ba33376011916b019ff5acf5cb83248fba983c8faa43f70cd70d4a90d417526fb46
+DIST Chart-cairo-1.2.tar.gz 4635 SHA256 8fd292ea36903434d8516b73ae8ecdce579b4500a2d5125e393e6fb1fc714a21 SHA512 310366341e7c21ee67dae600647c99c1fb3cf381335b26b572055d967ac957bab79411eb404a60be0c8a700aa0e737b37900740a90ae264b43cb57f162d02410 WHIRLPOOL 793e951c91ac0597562ea38b07fd6d8b91276ae1b254e978e09ec498eb96868b1d172b450e47611774c8b6e53cc528ecbb8b0924f06f5e74f35955e6ad02b2e2
View
42 dev-haskell/chart-cairo/chart-cairo-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Chart-cairo"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Cairo backend for Charts."
+HOMEPAGE="https://github.com/timbod7/haskell-chart/wiki"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cairo-0.9.11:=[profile?]
+ >=dev-haskell/chart-1.2:=[profile?] <dev-haskell/chart-1.3:=[profile?]
+ >=dev-haskell/colour-2.2.1:=[profile?] <dev-haskell/colour-2.4:=[profile?]
+ <dev-haskell/data-default-class-0.1:=[profile?]
+ >=dev-haskell/lens-3.9:=[profile?] <dev-haskell/lens-3.11:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/operational-0.2.2:=[profile?] <dev-haskell/operational-0.3:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'lens >= 3.9 && < 3.11' 'lens >= 3.9'
+}
Please sign in to comment.
Something went wrong with that request. Please try again.