Browse files

Bump yi-contrib to 0.6.6.0

  • Loading branch information...
1 parent b020f57 commit 441b0289a026f4ee70a72cfa5d946df2b79dddbf @markwright markwright committed Oct 13, 2012
View
2 app-editors/yi-contrib/Manifest
@@ -1 +1 @@
-DIST yi-contrib-0.6.5.0.tar.gz 16095 SHA256 76cfd10c8e51dace5d18edb97b8233c4c9e24aeac38544641ef0ce38a08fc63d SHA512 3c7e9f0b7371602921f9f49f095bb43ccafdcc060a20cb47531c93119fa5a3fb2f77800867ddbafe688c2bab66cb631977a737f67e9a680c567094f594712090 WHIRLPOOL bc144f15d7be51917f75f7269489b275174e108e54118175f974bfbd948ceca395b8b515619b4a337b70c28404108a278371c60e39e57fa755ee0d2b082c94f8
+DIST yi-contrib-0.6.6.0.tar.gz 16145 SHA256 e086b44cb40741efc40436a6e71afa0519b380d69367fe9922ed74134f57e113 SHA512 1249ac1dc9338a497a8177136a56f9eeedde6992f98d002078f1c40d6e645f223b10a5d9d1b25b9a397a4f2127a5b5619daeb04d3bc598a1d62bd968d95685eb WHIRLPOOL 17ed16a9afcff359d56b019dcf150e33d16cb039358e620b2e486bb4368d8de85a3107aa24106d6622d320dd7c5d22783852c03cd3c9f2a4b553c15abfe2e3b3
View
19 ...tors/yi-contrib/yi-contrib-0.6.5.0.ebuild → ...tors/yi-contrib/yi-contrib-0.6.6.0.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-# ebuild generated by hackport 0.2.13
+# $Header: $
EAPI=4
-CABAL_FEATURES="lib profile haddock hscolour"
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Add-ons to Yi, the Haskell-Scriptable Editor"
HOMEPAGE="http://haskell.org/haskellwiki/Yi"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="=dev-haskell/data-accessor-0.2*
- =dev-haskell/split-0.1*
- ~app-editors/yi-0.6.5.0
+RDEPEND="~app-editors/yi-0.6.6.0[profile?]
+ >=dev-haskell/data-accessor-0.2.1.4[profile?]
+ <dev-haskell/data-accessor-0.3[profile?]
+ =dev-haskell/split-0.1*[profile?]
>=dev-lang/ghc-6.10.1"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
@@ -29,4 +30,6 @@ src_prepare() {
if has_version "<dev-lang/ghc-7.0.1"; then
epatch "${FILESDIR}/${PN}-0.6.4.0-backport-to-ghc-6.12.3.patch"
fi
+ sed -e 's@directory < 1.2@directory < 1.3@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen dependencies"
}

0 comments on commit 441b028

Please sign in to comment.