Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Loosen unix-compat dep in yi

  • Loading branch information...
commit f56f893142fac3cfb1b66853084377ea7cc47596 1 parent 825b9dc
@markwright markwright authored
View
19 app-editors/yi/files/yi-0.6.6.0-backport-to-ghc-6.12.3.patch
@@ -1,4 +1,4 @@
---- yi-0.6.6.0-orig/yi.cabal 2012-10-13 19:15:43.741454954 +1100
+--- yi-0.6.6.0-orig/yi.cabal 2012-10-13 19:40:12.923138129 +1100
+++ yi-0.6.6.0/yi.cabal 2012-10-13 18:45:00.446156795 +1100
@@ -80,7 +80,7 @@
@@ -9,7 +9,7 @@
if flag(hacking)
buildable: False
-@@ -231,7 +231,7 @@
+@@ -231,12 +231,12 @@
regex-base ==0.93.*,
regex-tdfa == 1.1.*,
rosezipper >= 0.1 && < 0.3,
@@ -18,6 +18,21 @@
template-haskell >= 2.4 && < 2.9,
time >= 1.1 && < 1.5,
utf8-string >= 0.3.1,
+ uniplate,
+- unix-compat >=0.1 && <0.5,
++ unix-compat >=0.1 && <0.4,
+ unordered-containers >= 0.1.3 && < 0.3
+
+ build-tools: alex >= 3
+@@ -312,7 +312,7 @@
+ exposed-modules:
+ Yi.UI.Vty
+ build-depends:
+- unix-compat >=0.1 && <0.5,
++ unix-compat >=0.1 && <0.4,
+ vty >= 4.7.0.0 && <5
+ cpp-options: -DFRONTEND_VTY
+
@@ -360,7 +360,7 @@
buildable: False
View
18 app-editors/yi/files/yi-0.6.6.0-ghc-7.6.patch
@@ -1,5 +1,5 @@
--- yi-0.6.6.0-orig/yi.cabal 2012-07-21 16:15:35.000000000 +1000
-+++ yi-0.6.6.0/yi.cabal 2012-10-13 19:15:43.741454954 +1100
++++ yi-0.6.6.0/yi.cabal 2012-10-13 19:40:12.923138129 +1100
@@ -205,12 +205,12 @@
Parser.Incremental
@@ -15,7 +15,7 @@
cautious-file >= 1.0.1,
concrete-typerep == 0.1.*,
derive >=2.4 && <2.7,
-@@ -231,8 +231,8 @@
+@@ -231,12 +231,12 @@
regex-base ==0.93.*,
regex-tdfa == 1.1.*,
rosezipper >= 0.1 && < 0.3,
@@ -26,6 +26,20 @@
time >= 1.1 && < 1.5,
utf8-string >= 0.3.1,
uniplate,
+- unix-compat >=0.1 && <0.4,
++ unix-compat >=0.1 && <0.5,
+ unordered-containers >= 0.1.3 && < 0.3
+
+ build-tools: alex >= 3
+@@ -312,7 +312,7 @@
+ exposed-modules:
+ Yi.UI.Vty
+ build-depends:
+- unix-compat >=0.1 && <0.4,
++ unix-compat >=0.1 && <0.5,
+ vty >= 4.7.0.0 && <5
+ cpp-options: -DFRONTEND_VTY
+
--- yi-0.6.6.0-orig/src/library/Yi/UI/Pango.hs 2012-07-21 16:15:17.000000000 +1000
+++ yi-0.6.6.0/src/library/Yi/UI/Pango.hs 2012-10-13 18:08:47.021706305 +1100
@@ -1,4 +1,4 @@
View
2  app-editors/yi/yi-0.6.6.0.ebuild
@@ -53,7 +53,7 @@ RDEPEND="=dev-haskell/binary-0.5*[profile?]
<dev-haskell/time-1.5[profile?]
dev-haskell/uniplate[profile?]
>=dev-haskell/unix-compat-0.1[profile?]
- <dev-haskell/unix-compat-0.4[profile?]
+ <dev-haskell/unix-compat-0.5[profile?]
>=dev-haskell/unordered-containers-0.1.3[profile?]
<dev-haskell/unordered-containers-0.3[profile?]
>=dev-haskell/utf8-string-0.3.1[profile?]
Please sign in to comment.
Something went wrong with that request. Please try again.