Skip to content
Commits on Jul 28, 2010
  1. @kolmodin

    guess-ghc-version: Integrate GHC guessing into 'hackport merge'

    kolmodin committed Jul 28, 2010
    hackport will now attempt to guess which minimum ghc version is required to
    compile packages merged. If it fails it will use the default GHC dependency.
    It looks at all the dependencies, trying to identify all core packages used.
    As we don't allow upgrading of core packages, using this information we can
    sometimes make the dependency to ghc stricter.
    Also, hackport will not generate dependencies to cabal which are lower than
    what was shipped with the GHC version hackport knows the package requires.
  2. @kolmodin

    Remove commented code

    kolmodin committed Jul 28, 2010
Commits on Jun 13, 2010
  1. @kolmodin

    guess-ghc-version: Add a executable to run with .cabal files to guess…

    kolmodin committed Jun 13, 2010
    … its minimum ghc version
Something went wrong with that request. Please try again.