Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on Dec 24, 2011
  1. @trofi

    tagged 1.2.0.2 (ghc-7.4 support)

    trofi authored
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
  2. @trofi

    bump deps to support ghc-7.4 (Cabal-1.14 + filepath-1.3)

    trofi authored
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Commits on Jul 26, 2011
  1. @trofi

    bump deps to support ghc-7.2 (Cabal-1.12 + process-1.1)

    trofi authored
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Commits on Jul 5, 2011
  1. @trofi

    Distribution/Gentoo/GHC.hs: removed stale commented code

    trofi authored
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Commits on May 24, 2011
  1. @kolmodin
Commits on Apr 17, 2011
  1. @trofi

    cleanup: changed tab to space

    trofi authored
Commits on Jan 16, 2011
  1. @ivan-m
  2. @ivan-m

    Bump version to 1.2.0.0

    ivan-m authored
  3. @ivan-m
  4. @ivan-m
  5. @ivan-m
Commits on Aug 7, 2010
  1. @ivan-m

    Set version to 1.1.3.0

    ivan-m authored
Commits on Aug 4, 2010
  1. @ivan-m

    Add support for cave

    ivan-m authored
    cave is a new front-end for paludis
  2. @ivan-m
Commits on Aug 1, 2010
  1. @ivan-m

    TAG 1.1.2.0

    ivan-m authored
  2. @ivan-m

    Set version to 1.1.2.0

    ivan-m authored
Commits on Jul 31, 2010
  1. @ivan-m
  2. @ivan-m

    A much nicer and faster version of allInstalledPackages

    ivan-m authored
    Went from about 3 minutes to instant!
  3. @ivan-m

    Add an --all option to GHC

    ivan-m authored
    Rebuilds all libraries installed with the current version of GHC
Commits on Jul 30, 2010
  1. @ivan-m

    Get rid of useless comment

    ivan-m authored
    Was from when I was trying out parsing the output of "ghc-pkg check
    --simple-output" before I renamed it to getBroken.
Commits on Jul 29, 2010
  1. @ivan-m

    Set version to 1.1.1.0

    ivan-m authored
  2. @ivan-m

    Rather than using brokenPackages from Cabal, just parse "ghc-pkg chec…

    ivan-m authored
    …k --simple-output"
    
    The rationale for this is that brokenPackages doesn't work for
    packages that have include directories missing (e.g. dev-haskell/gtk,
    but x11-libs/gtk+ gets upgraded).  "ghc-pkg check" already takes this
    into account, so rather than trying to duplicate this functionality
    just parse what it spits out.
Commits on Jun 12, 2010
  1. @kolmodin

    proper bugfix: ghc version x.y.z is not same as version x.y

    kolmodin authored
    haskell-updater was treating ghc 6.12.2.20100521 as the same version as
    6.12.2, this patch makes it into two separate versions.
Commits on May 28, 2010
  1. @kolmodin

    rollback the attempt to fix version trouble

    kolmodin authored
    Instead, it forced all packages to be recompiled all the time.
    Things are not as easy as they seem...
    
    rolling back:
    
    Thu May 27 23:28:21 CEST 2010  Lennart Kolmodin <kolmodin@gentoo.org>
      * bugfix: ghc version x.y.z is not same as version x.y
      haskell-updater was treating ghc 6.12.2.20100521 as the same version as
      6.12.2, this patch makes it into two separate versions.
    
        M ./Distribution/Gentoo/GHC.hs -1 +1
  2. @ivan-m
Commits on May 27, 2010
  1. @kolmodin

    bugfix: ghc version x.y.z is not same as version x.y

    kolmodin authored
    haskell-updater was treating ghc 6.12.2.20100521 as the same version as
    6.12.2, this patch makes it into two separate versions.
Commits on May 23, 2010
  1. @ivan-m

    TAG 1.1.0.0

    ivan-m authored
  2. @ivan-m

    Set version as 1.1.0.0

    ivan-m authored
  3. @ivan-m
Commits on May 19, 2010
  1. @jkarlson
Commits on May 9, 2010
  1. @ivan-m
Commits on May 7, 2010
  1. @ivan-m

    Start using Cabal-1.6 features

    ivan-m authored
    Specify the darcs repo and use explicit deps for base and Cabal
  2. @ivan-m
  3. @ivan-m

    Specify with the other information which package manager is being used.

    ivan-m authored
    An extension to the fix for bug 317551
  4. @ivan-m

    If the environment variable PACKAGE_MANAGER exists, default to that.

    ivan-m authored
    As requested by bug 317551.
Something went wrong with that request. Please try again.