Release GeoExt 2.1.0 (Compatibility ExtJS 4 and 5)

@chrismayer chrismayer released this Nov 25, 2015 · 22 commits to master since this release

This is the first stable release of the GeoExt 2.1.0 series.

GeoExt v2.1.0 introduces the compatibility to both ExtJS 4 and ExtJS 5. The base work for this has been done in the pull request #339.

Users are encouraged to upgrade to this version, since it introduces no backwards incompatible changes.

List of most relevant changes since version 2.0.3:

Fix JavaScript error when the map panel is loaded in a hidden ExtJS tab (#367)
Fix PrintProviderField to work with textboxes (#364)
Set correct version numbers (#362)
Adapt README for Version 2.1.x (#361)
Dispose layer tree node event listeners. (#357)
Fix accidental overwrite of alternateClassName of WMSCapabilitiesReader. (#353)
Introduce ExtJS 5 example app (#352)
Adopt minimal Sencha Cmd package requirements (#350)
Add outputFormat as a none-custom param of MapfishPrintProvider (#349)
Correct minimal app example in README (#346)
Add more API docs for disabled LayerTreeNodes (#344)
Add visual feedback of layers out of range to tree panel (#343)
Support both ExtJS 4.2.1 and ExtJS 5.1.0 (#339)

Downloads

Third beta-release for v2.1.0 (Compatibility ExtJS 4 and 5)

@chrismayer chrismayer released this Nov 4, 2015 · 25 commits to master since this release

This is the follow-up beta release of GeoExt v2.1.0-beta.2, which mainly contains the bugfix provided in #367.

Downloads

Second beta-release for v2.1.0 (Compatibility ExtJS 4 and 5)

@chrismayer chrismayer released this Sep 25, 2015 · 31 commits to master since this release

This is the follow-up beta release of GeoExt v2.1.0-beta.1, which mainly contains the bugfix provided in #364.

Downloads

First beta-release for v2.1.0 (Compatibility ExtJS 4 and 5)

@chrismayer chrismayer released this Sep 2, 2015 · 37 commits to master since this release

This is the first beta release for the 2.1.0 version of GeoExt. GeoExt v2.1.0 is supposed to introduce the compatibility to ExtJS 4 and 5.

The changelog since the last 2.1.0-alpha.1 release:

  • #357 Dispose layer tree node event listeners.
  • #361 Adapt README for Version 2.1.x
  • #352 Introduce ExtJS 5 example app
  • #349 Add outputFormat as a none-custom param of MapfishPrintProvider
  • #353 Fix accidental overwrite of alternateClassName of
    WMSCapabilitiesReader.
  • #350 Adopt minimal Sencha Cmd package requirements

Downloads

First alpha-release for v2.1.0 (Compatibility ExtJS 4 and 5)

@chrismayer chrismayer released this Apr 7, 2015 · 56 commits to master since this release

This is the first alpha release for the 2.1.0 version of GeoExt. GeoExt v2.1.0 is supposed to introduce the compatibility to ExtJS 4 and 5. This has mainly been done by the PR #339.

Downloads

Bugfix release v2.0.3

@marcjansen marcjansen released this Mar 18, 2015 · 209 commits to master since this release

This is the third bugfix release for GeoExt in version 2.0.x.

Users are encouraged to upgrade to this version, since it introduces no backwards incompatible changes.

Relevant changes since v2.0.2

Downloads

Bugfix release 2.0.2

@chrismayer chrismayer released this Jul 16, 2014 · 274 commits to master since this release

This is the second bugfix release for GeoExt in version 2.0.x.

Users are encouraged to upgrade to this version, since it introduces no backwards incompatible changes.

Solved issues since v2.0.1

Downloads

Bugfix release 2.0.1

@chrismayer chrismayer released this Mar 20, 2014 · 342 commits to master since this release

This is the first bugfix release for GeoExt in version 2.0.x. Following issues have been resolved:

  • Fix GeoExt.Version #201
  • Use theme-switcher in examples #202
  • Made GeoExt.LayerModel extendable #203
  • Refactor sliders #204 #205
  • Testsuite enhancements #211 #214
  • various minor bugfixes

Downloads