A compilation error occurs without hibernate plugin #9

Open
literalice opened this Issue Sep 2, 2011 · 3 comments

Projects

None yet

3 participants

@literalice

Thank you for creating this great plugin.

I have uninstalled hibernate plugin because I wanted to use only MongoDB for the data source.
When I installed the custom constraints plugin, a compilation error occurred.

The error message said that "DefaultGrailsConstraintClass.java" has a dependency to hibernate plugin(org.hibernate.SessionFactory).

Are there any ways to avoid this error?

@geofflane
Owner

I'm glad you like the plugin.

As far as I can tell there's no way to avoid the dependency as it's currently constructed. To solve it I might need to split the plugin into a "core" and a "hibernate" plugin. I'm not sure what that would involve at this point.

@literalice

Thank you for the reply. I'm looking forward to the "core" plugin.
I'll consider re-installing the hibernate plugin tentatively.

@geofflane geofflane was assigned Dec 16, 2011
@cdeszaq
cdeszaq commented Apr 27, 2012

I'm not sure how the non-hibernate GORM plugins handle constraints that need to access the data store while validating, but if you can shift the dependency to be on GORM, rather than on hibernate directly, that should be able to solve the issue of being tied to hibernate.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment