Permalink
Browse files

ant code simplification

cygwin has been added to a list of prerequisits
(cherry picked from commit fcaba4b4fe7594122e20e14d1cd5ee254e8c24c0)
  • Loading branch information...
1 parent 709a483 commit 42f8ebe0c0a5b84f1395b520f6cac682def50825 @geometer committed with vasiliy-bout Nov 20, 2010
Showing with 4 additions and 7 deletions.
  1. +3 −1 HowToBuild
  2. +1 −6 build.xml
View
@@ -7,7 +7,9 @@ Prerequisites:
2. Android NDK >= r4b
-3. Apache Ant >= 1.7.1
+3. Apache Ant >= 1.7.0
+
+4. (Windows-only) Cygwin >= 1.7
To build:
View
@@ -19,15 +19,10 @@
<setup />
<target name="init" description="Initialization...">
- <condition property="Ant17isOnline">
- <and>
- <antversion property="ant.version" atleast="1.7.0"/>
- </and>
- </condition>
<fail message="ANT with version at least 1.7 should be present !!! Update your local '${ant.version}' first.">
<condition>
<not>
- <isset property="Ant17isOnline"/>
+ <antversion property="ant.version" atleast="1.7.0"/>
</not>
</condition>
</fail>

0 comments on commit 42f8ebe

Please sign in to comment.