New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

docker-compose.yml version problem #179

Closed
MarcoDuiker opened this Issue Dec 22, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@MarcoDuiker

MarcoDuiker commented Dec 22, 2017

In my docker-compose (version 1.6.0, build d99cad6) the command
docker-compose -f docker-compose.yml up gives the following error:

ERROR: Version in "./docker-compose.ori.yml" is unsupported. Either specify a version of "2" (or "2.0") and place your service definitions under the services key, or omit the version key and place your service definitions at the root of the file to use version 1.
For more on the Compose file format versions, see https://docs.docker.com/compose/compose-file/

Changing line two to:
version: "2"

Solves the error.

@justb4

This comment has been minimized.

Member

justb4 commented Dec 22, 2017

You run quite an old version of docker-compose (and maybe Docker)?
See https://docs.docker.com/compose/compose-file/compose-versioning/, is it possible that you upgrade to compose v3+?
In many cases a docker-compose.yml serves as an example to be adapted locally.

@MarcoDuiker

This comment has been minimized.

MarcoDuiker commented Dec 23, 2017

Thank you.
It would be nice to adapt the docs (https://github.com/geopython/GeoHealthCheck/blob/master/docker/README.md) to reflect that the docker-compose files serve as examples only.

@justb4 justb4 self-assigned this Dec 24, 2017

@justb4 justb4 added the enhancement label Dec 24, 2017

@justb4 justb4 added this to the Version 0.4.0 milestone Dec 24, 2017

justb4 added a commit that referenced this issue Dec 24, 2017

@justb4 justb4 closed this Dec 24, 2017

justb4 added a commit that referenced this issue Dec 24, 2017

Merge pull request #184 from geopython/dev
#179 extend README.md w.r.t. docker-compose and PG deployment
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment