Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump flask from 0.12.4 to 1.0 #269

Closed
wants to merge 1 commit into from

Conversation

@dependabot @github
Copy link

dependabot bot commented on behalf of github Jul 19, 2019

Bumps flask from 0.12.4 to 1.0.

Release notes

Sourced from flask's releases.

1.0

The Pallets team is pleased to release Flask 1.0. [Read the announcement on our blog.](https://www.palletsprojects.com/blog/flask-1-0-released/

There are over a year's worth of changes in this release. Many features have been improved or changed. Read the changelog to understand how your project's code will be affected.

JSON Security Fix

Flask previously decoded incoming JSON bytes using the content type of the request. Although JSON should only be encoded as UTF-8, Flask was more lenient. However, Python includes non-text related encodings that could result in unexpected memory use by a request.

Flask will now detect the encoding of incoming JSON data as one of the supported UTF encodings, and will not allow arbitrary encodings from the request.

Install or Upgrade

Install from PyPI with pip:

pip install -U Flask
Changelog

Sourced from flask's changelog.

Version 1.0

Released 2018-04-26

  • Python 2.6 and 3.3 are no longer supported.
  • Bump minimum dependency versions to the latest stable versions:
    Werkzeug >= 0.14, Jinja >= 2.10, itsdangerous >= 0.24, Click >= 5.1.
    :issue:2586
  • Skip :meth:app.run <Flask.run> when a Flask application is run
    from the command line. This avoids some behavior that was confusing
    to debug.
  • Change the default for :data:JSONIFY_PRETTYPRINT_REGULAR to
    False. :func:~json.jsonify returns a compact format by
    default, and an indented format in debug mode. :pr:2193
  • :meth:Flask.__init__ <Flask> accepts the host_matching
    argument and sets it on :attr:~Flask.url_map. :issue:1559
  • :meth:Flask.__init__ <Flask> accepts the static_host argument
    and passes it as the host argument when defining the static
    route. :issue:1559
  • :func:send_file supports Unicode in attachment_filename.
    :pr:2223
  • Pass _scheme argument from :func:url_for to
    :meth:~Flask.handle_url_build_error. :pr:2017
  • :meth:~Flask.add_url_rule accepts the
    provide_automatic_options argument to disable adding the
    OPTIONS method. :pr:1489
  • :class:~views.MethodView subclasses inherit method handlers from
    base classes. :pr:1936
  • Errors caused while opening the session at the beginning of the
    request are handled by the app's error handlers. :pr:2254
  • Blueprints gained :attr:~Blueprint.json_encoder and
    :attr:~Blueprint.json_decoder attributes to override the app's
    encoder and decoder. :pr:1898
  • :meth:Flask.make_response raises TypeError instead of
    ValueError for bad response types. The error messages have been
    improved to describe why the type is invalid. :pr:2256
  • Add routes CLI command to output routes registered on the
    application. :pr:2259
  • Show warning when session cookie domain is a bare hostname or an IP
    address, as these may not behave properly in some browsers, such as
    Chrome. :pr:2282
  • Allow IP address as exact session cookie domain. :pr:2282
  • SESSION_COOKIE_DOMAIN is set if it is detected through
    SERVER_NAME. :pr:2282
  • Auto-detect zero-argument app factory called create_app or
    make_app from FLASK_APP. :pr:2297
  • Factory functions are not required to take a script_info
    parameter to work with the flask command. If they take a single
    parameter or a parameter named script_info, the
... (truncated)
Commits

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot ignore this [patch|minor|major] version will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Bumps [flask](https://github.com/pallets/flask) from 0.12.4 to 1.0.
- [Release notes](https://github.com/pallets/flask/releases)
- [Changelog](https://github.com/pallets/flask/blob/master/CHANGES.rst)
- [Commits](pallets/flask@0.12.4...1.0)

Signed-off-by: dependabot[bot] <support@github.com>
@dependabot dependabot bot added the dependencies label Jul 19, 2019
@tomkralidis tomkralidis requested a review from justb4 Jul 19, 2019
@borrob

This comment has been minimized.

Copy link
Collaborator

borrob commented Oct 28, 2019

FYI: In the py3 PR (#280), I updated the flask dependence to version 1.1.1.

@dependabot @github

This comment has been minimized.

Copy link
Author

dependabot bot commented on behalf of github Nov 27, 2019

Looks like flask is up-to-date now, so this is no longer needed.

@dependabot dependabot bot closed this Nov 27, 2019
@dependabot dependabot bot deleted the dependabot/pip/flask-1.0 branch Nov 27, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.