Can pywps be installed with pip? #227

Open
Alexander-Barth opened this Issue Jan 18, 2017 · 3 comments

Projects

None yet

3 participants

@Alexander-Barth

Description

I am wondering if pywps is supposed to be installable using pip. Currently pip only finds an old version not installable using python 3.4

Environment

  • operating system:
    Ubuntu 14.04
  • Python version:
    Python 3.4.3
  • PyWPS version:
  • source/distribution
  • git clone
  • Debian
  • PyPI
  • zip/tar.gz
  • other (please specify):
    pip
  • web server
  • Apache/mod_wsgi
  • CGI
  • other (please specify):

Steps to Reproduce

$ pip3 install --user pywps==4.0.0
Downloading/unpacking pywps==4.0.0
  Could not find a version that satisfies the requirement pywps==4.0.0 (from versions: 3.2.6)
Cleaning up...
No distributions matching the version for pywps==4.0.0
Storing debug log for failure in /home/abarth/.pip/pip.log

without requiring any version:

 pip3 install --user pywps
Downloading/unpacking pywps
  Downloading pywps-3.2.6.tar.gz (123kB): 123kB downloaded
  Running setup.py (path:/tmp/pip_build_abarth/pywps/setup.py) egg_info for package pywps
    Traceback (most recent call last):
      File "<string>", line 17, in <module>
      File "/tmp/pip_build_abarth/pywps/setup.py", line 32
        print "Compiling template "+template_file+" in "+base
                                  ^
    SyntaxError: Missing parentheses in call to 'print'
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 17, in <module>

  File "/tmp/pip_build_abarth/pywps/setup.py", line 32

    print "Compiling template "+template_file+" in "+base

                              ^

SyntaxError: Missing parentheses in call to 'print'

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip_build_abarth/pywps
Storing debug log for failure in /home/abarth/.pip/pip.log

Additional Information

@ldesousa
Contributor

I am getting similar errors, even though the PyPi repository reports 4.0.0 as the latest version.

@Alexander-Barth
@jachym jachym added the bug label Jan 20, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment