Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

288 lines (268 sloc) 9.226 kb
<?xml version="1.0" encoding="UTF-8"?>
<!-- =======================================================================
Maven Project Configuration File
The Geotools Project
http://www.geotools.org/
Version: $Id: pom.xml 34196 2009-10-22 13:32:49Z groldan $
======================================================================= -->
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.geotools</groupId>
<artifactId>geotools</artifactId>
<version>9-SNAPSHOT</version>
</parent>
<!-- =========================================================== -->
<!-- Module Description -->
<!-- =========================================================== -->
<groupId>org.geotools</groupId>
<artifactId>docs</artifactId>
<name>GeoTools Documentation</name>
<description>GeoTools website, user and developer guides.</description>
<licenses>
<license>
<name>Lesser General Public License (LGPL)</name>
<url>http://www.gnu.org/copyleft/lesser.txt</url>
<distribution>repo</distribution>
</license>
</licenses>
<!-- =========================================================== -->
<!-- Developers and Contributors -->
<!-- =========================================================== -->
<developers>
<developer>
<name>Jody Garnett</name>
<id>jive</id>
<email>jgarnett@gmail.com</email>
<organization>Open Source Geospatial Foundation</organization>
<roles>
<role>Module Maintainer</role>
</roles>
</developer>
</developers>
<!-- =========================================================== -->
<!-- Dependency Management -->
<!-- =========================================================== -->
<dependencies>
<!-- GeoTools Library modules -->
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-main</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-cql</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-render</artifactId>
<version>${project.version}</version>
</dependency>
<!-- GeoTools Plugins -->
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-shapefile</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-property</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools.jdbc</groupId>
<artifactId>gt-jdbc-postgis</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-wfs</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-geotiff</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-image</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-epsg-hsql</artifactId>
<version>${project.version}</version>
</dependency>
<!-- GeoTools Extensions -->
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-wms</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools.xsd</groupId>
<artifactId>gt-xsd-filter</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools.xsd</groupId>
<artifactId>gt-xsd-kml</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools.xsd</groupId>
<artifactId>gt-xsd-sld</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-brewer</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-graph</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-swing</artifactId>
<version>${project.version}</version>
</dependency>
<!-- Other GeoTools modules -->
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-process</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-process-feature</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-process-geometry</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-process-raster</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-grid</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.geotools</groupId>
<artifactId>gt-validation</artifactId>
<version>${project.version}</version>
</dependency>
<!-- Other dependencies -->
<dependency>
<groupId>commons-io</groupId>
<artifactId>commons-io</artifactId>
</dependency>
<dependency>
<groupId>org.apache.xmlgraphics</groupId>
<artifactId>batik-svggen</artifactId>
<!-- The version number is specified in the parent POM. -->
</dependency>
<dependency>
<groupId>org.apache.xmlgraphics</groupId>
<artifactId>batik-awt-util</artifactId>
<!-- The version number is specified in the parent POM. -->
</dependency>
<dependency>
<groupId>net.sourceforge.javacsv</groupId>
<artifactId>javacsv</artifactId>
<version>2.0</version>
</dependency>
<dependency>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
<version>2.1.13</version>
</dependency>
<dependency>
<groupId>javax.media</groupId>
<artifactId>jai_core</artifactId>
<!-- The version number is specified in the parent POM. -->
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<artifactId>maven-antrun-plugin</artifactId>
<dependencies>
<dependency>
<groupId>ant</groupId>
<artifactId>ant</artifactId>
<version>1.6.5</version>
</dependency>
<dependency>
<groupId>ant-contrib</groupId>
<artifactId>ant-contrib</artifactId>
<version>1.0b3</version>
</dependency>
</dependencies>
<executions>
<execution>
<id>compile</id>
<phase>compile</phase>
<configuration>
<tasks>
<ant antfile="build.xml" dir="${basedir}" target="${target}">
<property name="build.directory" value="${build.directory}"/>
<!-- may be ${project.version} when tagged -->
<property name="project.version" value="${project.version}"/>
</ant>
</tasks>
</configuration>
<goals>
<goal>run</goal>
</goals>
</execution>
</executions>
</plugin>
</plugins>
</build>
<properties>
<target>full</target>
</properties>
<profiles>
<profile>
<id>index</id>
<properties>
<target>index</target>
</properties>
</profile>
<profile>
<id>user</id>
<properties>
<target>user</target>
</properties>
</profile>
<profile>
<id>web</id>
<properties>
<target>web</target>
</properties>
</profile>
<profile>
<id>developer</id>
<properties>
<target>developer</target>
</properties>
</profile>
</profiles>
</project>
Jump to Line
Something went wrong with that request. Please try again.