Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

node dimming does not work well with non-white background #738

Closed
libor-m opened this Issue Feb 6, 2013 · 5 comments

Comments

Projects
None yet
3 participants

libor-m commented Feb 6, 2013

When hovering a node in gephi, the adjacent nodes and links are shown, the rest is dimmed.
If the background color is anything else than white, the dimming does not really work, because the nodes are blended with white instead of real background color.

Koheiru commented May 7, 2013

It looks like that every items use alpha channel for dimming (so it looks alright), but nodes use special parameter (in code it called "HIGHTLIGHT_COLOR") which is by default ~white and can not be changed in GUI. Therefore, color of dimmed nodes is not dependent of background color =(

Koheiru commented May 7, 2013

Maybe it would be more convinient to remove some hardcoded parameters which are define "select", "unselect", "highlight" and some other colors and instead use two parameters - opacity factor for unselected items and highlight factor for selected. Then real color will be based on this two parameters, item color and background color. More over this parameters would be simple to use by user in preferences panel.

libor-m commented May 7, 2013

Sounds like a reasonable propositon - but maybe there are some reasons for the current state that we are not aware of..

Koheiru commented May 7, 2013

Maybe... therefore I will wait comments from Gephi members before any implementations.

Owner

eduramiba commented Aug 20, 2017

This should be fixed with #1728 To be released with 0.9.2

@eduramiba eduramiba closed this Aug 20, 2017

@eduramiba eduramiba self-assigned this Aug 20, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment