Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
71 lines (71 sloc) 2.23 KB
{
"name": "gersom.nl",
"private": true,
"description": "Personal Website of Gersom van Ginkel",
"version": "1.0.0",
"author": "Gersom van Ginkel <inbox@gersom.nl>",
"scripts": {
"build": "gatsby build",
"develop": "gatsby develop",
"start": "npm run develop",
"serve": "gatsby serve",
"prettier": "prettier --ignore-path .gitignore \"**/*.+(js|json|md|ts|tsx)\"",
"format": "npm run prettier -- --write",
"check-format": "npm run prettier -- --list-different",
"check-types": "tsc",
"test": "jest",
"test-watch": "npm run test -- --watch",
"validate": "npm-run-all --parallel check-types check-format test build"
},
"dependencies": {
"@mdx-js/mdx": "^1.5.1",
"@mdx-js/react": "^1.5.1",
"chrome-aws-lambda": "^2.0.2",
"gatsby": "^2.18.12",
"gatsby-image": "^2.2.34",
"gatsby-plugin-catch-links": "^2.1.19",
"gatsby-plugin-env-variables": "^1.0.1",
"gatsby-plugin-manifest": "^2.2.31",
"gatsby-plugin-mdx": "^1.0.59",
"gatsby-plugin-react-helmet": "^3.1.16",
"gatsby-plugin-sharp": "^2.3.5",
"gatsby-plugin-styled-components": "^3.1.14",
"gatsby-plugin-typescript": "^2.1.20",
"gatsby-plugin-typescript-checker": "^1.1.1",
"gatsby-remark-images": "^3.1.37",
"gatsby-remark-prismjs": "^3.3.27",
"gatsby-source-filesystem": "^2.1.40",
"gatsby-transformer-sharp": "^2.3.7",
"lodash": "^4.17.15",
"prismjs": "^1.17.1",
"puppeteer-core": "^2.0.0",
"react": "^16.12.0",
"react-dom": "^16.12.0",
"react-helmet": "^5.2.1",
"styled-components": "^4.4.1"
},
"devDependencies": {
"@testing-library/react": "^9.4.0",
"@types/jest": "^24.0.23",
"@types/lodash": "^4.14.149",
"@types/node": "^12.12.15",
"@types/react": "^16.9.16",
"@types/react-dom": "^16.9.4",
"@types/react-helmet": "^5.0.14",
"@types/styled-components": "^4.4.0",
"babel-jest": "^24.9.0",
"babel-plugin-styled-components": "^1.10.6",
"babel-preset-gatsby": "^0.2.26",
"husky": "^3.1.0",
"jest": "^24.9.0",
"lint-staged": "^9.5.0",
"npm-run-all": "^4.1.5",
"prettier": "^1.19.1",
"puppeteer": "^2.0.0",
"typescript": "^3.7.3"
},
"license": "MIT",
"engines": {
"node": "12.13.0"
}
}
You can’t perform that action at this time.