Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Video tag width/height not correctly assigned #1875

Closed
texnixe opened this issue Jun 20, 2019 · 1 comment

Comments

@texnixe
Copy link
Contributor

commented Jun 20, 2019

Describe the bug
When embedding a video via the (video: somevideo width: 900 height: 800) Kirbytag and setting a width and height attribute, the output is:

<figure class="video" height="800" width="900"><iframe allowfullscreen="" src="https://youtube.com/embed/lLuc6rtWkrM"></iframe></figure>

However, the output should be:

<figure class="video" style="height:800px; width:"900px"><iframe allowfullscreen="" src="https://youtube.com/embed/lLuc6rtWkrM"></iframe></figure>

so that the iframe can then be set to 100% width and height of the container.

Or the width and height applied to the iframe like in the Kirby 2 YouTube tag.

To Reproduce
Steps to reproduce the behavior:

  1. Insert the above video tag into a textarea field
  2. Open the page in the browser
  3. See error

Expected behavior
The tag should apply inline styles to the figure tag instead of using image-style width and height attributes.

Tested with Kirby 3.2.0-rc4.

@bastianallgeier

This comment has been minimized.

Copy link
Contributor

commented Jul 29, 2019

The width and height attributes are now assigned to the iframe

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
3 participants
You can’t perform that action at this time.