Skip to content
Permalink
Browse files

Specify doit versions in setup.py instead of requirements.txt

Signed-off-by: Chris Warrick <kwpolska@gmail.com>
  • Loading branch information
Kwpolska committed Jan 10, 2017
1 parent 17d00a1 commit 46186d19cbfcc2086f83390b004488e3cab00347
Showing with 6 additions and 3 deletions.
  1. +2 −0 requirements-rtd.txt
  2. +0 −2 requirements.txt
  3. +4 −1 setup.py
@@ -0,0 +1,2 @@
-r requirements.txt
doit
@@ -1,5 +1,3 @@
doit>=0.28.0,<=0.29.0 ; python_version <= '3.3' # rq.filter: <=0.29.0
doit>=0.28.0 ; python_version >= '3.4'
Pygments>=1.6
Pillow>=2.4.0
python-dateutil>=2.4.0
@@ -26,7 +26,10 @@ def run_tests(self):
with open('requirements.txt', 'r') as fh:
dependencies = [l.strip() for l in fh]

extras = {}
extras = {
':python_version >= "3.4"': ['doit>=0.28.0'],
':python_version <= "3.3"': ['doit>=0.28.0,<=0.29.0'],
}

with open('requirements-extras.txt', 'r') as fh:
extras['extras'] = [l.strip() for l in fh][1:]

0 comments on commit 46186d1

Please sign in to comment.
You can’t perform that action at this time.