Skip to content
Permalink
Browse files
Merge pull request #2882 from getnikola/auto-aiohttp
Fix #2850 — rewrite `nikola auto` with asyncio and aiohttp
  • Loading branch information
Kwpolska committed Aug 1, 2017
2 parents a53a31f + 0fdadf5 commit 47d57ee4fa6e223c40fe08d4ab19996b5ab9f20f
Showing with 318 additions and 303 deletions.
  1. +0 −2 .travis.yml
  2. +2 −1 CHANGES.txt
  3. +1 −1 README.rst
  4. +1 −1 docs/manual.txt
  5. +308 −271 nikola/plugins/command/auto/__init__.py
  6. +2 −2 requirements-extras.txt
  7. +0 −7 scripts/getwheelhouse.sh
  8. +4 −18 setup.py
@@ -12,7 +12,6 @@ addons:
- language-pack-en-base
- language-pack-pl-base
python:
- '3.3'
- '3.4'
- '3.5'
- '3.6'
@@ -36,7 +35,6 @@ env:
global:
secure: GqUDW0j4Ay8pS9tS/g5JBYGtgBG0g0oD2g4X9JXgVchiFj3GIRL+dwiXpgx3LELy7nCWF3EzClFxxMdVqqxizQ/I8xqiA0XL/rf5z/y+9d9nmKOxV8SV73n0eCgsHWkbdSLJ6MKs6s0Trlz9jLu/P+Bhfu2ttqkOH8WttfEf3VE=
install:
- if [[ $NMODE == 'nikola' ]]; then scripts/getwheelhouse.sh $(scripts/getpyver.py short); fi
- if [[ $NMODE == 'nikola' ]]; then pip install -r requirements-tests.txt; if [[ "$?" == '1' ]]; then cat /home/travis/.pip/pip.log; false; fi; fi
- if [[ $NMODE == 'nikola' ]]; then pip install .; fi
- if [[ $NMODE == 'flake8' ]]; then pip install flake8 pydocstyle; fi
@@ -4,6 +4,7 @@ New in master
Features
--------

* Rewrite ``nikola auto`` with asyncio and aiohttp (Issue #2850)
* New ``listings`` shortcode similar to the reStructuredText listings
directive (Issue #2868)
* Switch to reStructuredText’s new HTML 5 renderer (Issue #2874)
@@ -36,7 +37,7 @@ Removed features
----------------

* Removed the slides directive for docutils, it will now be a separate plugin.
* Drop Python 2 support
* Drop Python 2 and Python 3.3 support (oldest supported version is 3.4)
* Remove ``nikola install_theme`` — use ``nikola theme`` instead
* Drop insecure post encryption feature
* Stop supporting all deprecated config options
@@ -43,7 +43,7 @@ It has many features, but here are some of the nicer ones:
* Syntax highlighting for almost any programming language or markup
* Multilingual sites, `translated to 50 languages.`__
* Doesn't reinvent wheels, leverages existing tools.
* Python 3.3+ compatible.
* Python 3.4+ compatible.

.. _Nikola Handbook: https://getnikola.com/handbook.html#why-static
__ https://users.getnikola.com/
@@ -136,7 +136,7 @@ Obsolescence
You may say those are long term issues, or that they won't matter for years. Well,
I believe things should work forever, or as close to it as we can make them.
Nikola's static output and its input files will work as long as you can install
Python 3.3 or newer under Linux, Windows, or OS X and can find a server
Python 3.4 or newer under Linux, Windows, or OS X and can find a server
that sends files over HTTP. That's probably 10 or 15 years at least.

Also, static sites are easily handled by the Internet Archive.

0 comments on commit 47d57ee

Please sign in to comment.