New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Changing section colors does not rebuild things #2066

Closed
Kwpolska opened this Issue Sep 11, 2015 · 2 comments

Comments

Projects
None yet
3 participants
@Kwpolska
Member

Kwpolska commented Sep 11, 2015

I want to use section colors in all post headers, and I have to run nikola build -a to get the changes to appear everywhere.

@Kwpolska Kwpolska added this to the 7.7.1 milestone Sep 11, 2015

@ralsina

This comment has been minimized.

Show comment
Hide comment
@ralsina

ralsina Sep 15, 2015

Member

We should probably just add POSTS_SECTION_COLORS to the global context, right?

Member

ralsina commented Sep 15, 2015

We should probably just add POSTS_SECTION_COLORS to the global context, right?

@ralsina ralsina added the PR exists label Sep 15, 2015

@ralsina ralsina closed this in e857096 Sep 15, 2015

@Kwpolska

This comment has been minimized.

Show comment
Hide comment
@Kwpolska

Kwpolska Sep 15, 2015

Member

We actually need all the POSTS_SECTION_* things there, for other things to get rebuilt. I’ll add them in.

Member

Kwpolska commented Sep 15, 2015

We actually need all the POSTS_SECTION_* things there, for other things to get rebuilt. I’ll add them in.

Kwpolska added a commit that referenced this issue Sep 15, 2015

Really fix #2066
* add POSTS_SECTION_COLORS to default settings
* add all postS_section* settings to global context
* fix typo in existing global setting

Signed-off-by: Chris Warrick <kwpolska@gmail.com>

ralsina added a commit that referenced this issue Sep 15, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment