Skip to content
This repository

get_version chokes on django.db.backends.postgresql_psycopg2.base #143

Closed
tbaugis opened this Issue July 06, 2012 · 0 comments

2 participants

Toms Bauģis David Cramer
Toms Bauģis

when raven tries to determine version it goes for different approaches, this get_version call here https://github.com/dcramer/raven/blob/master/raven/utils/__init__.py#L64

dies when trying to call this evil bit:
https://github.com/django/django/blob/master/django/db/backends/postgresql_psycopg2/version.py#L24

i think just wrapping it up in a try/except should suffice

thank you for the awesome tool!

David Cramer dcramer closed this in 5c49f87 August 22, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.