Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sample for AspNetMvc5Ef6 can't find SentrySdk #4

Closed
TimberToe opened this issue Oct 30, 2018 · 7 comments

Comments

Projects
None yet
2 participants
@TimberToe
Copy link

commented Oct 30, 2018

Steps to reproduce:

  • Download repo
  • Open solution for AspNetMvc5Ef6 (By double clicking on AspNetMvc5Ef6/AspNetMvc5Ef6.sln)
  • Build project
  • You get 2 build errors: "The name 'SentrySdk' does not exist in the current context"

I have .NET 4.7 installed on my system

Minor note: The samples use Sentry 0.0.1-preview2, should'nt they be updated to 1.0.0?

@bruno-garcia

This comment has been minimized.

Copy link
Member

commented Oct 30, 2018

@TimberToe the EntityFramework package hasn't been updated yet.
The issue is being tracked here: getsentry/sentry-dotnet-ef#4

To use the sample please use the versions that are already specified.
We can update the sample once the new EF package is released.

@TimberToe

This comment has been minimized.

Copy link
Author

commented Nov 2, 2018

Ah, I think you missunderstood me. I have not changed anything in the sample.
I only did the steps laid out in the issue description.

I'm honestly not interested in the EntityFramework. We only want to evaluate Sentry to see if it works in our legacy codebase. We don't use EntityFramework in that code.

@bruno-garcia

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

@TimberToe In this case I'd suggest using Sentry package directly which is passed preview phase. The EF package needs a bit of work as per the issue I linked before.

I'll make sure the sample is fixed as soon as the EF 1.0.0 is out.

@bruno-garcia bruno-garcia added the bug label Nov 2, 2018

@bruno-garcia

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

I checked the sample now and it's broken for me too. I'm afraid it has to do with Windows Updates and .NET 4.7.1+

See this thread for more: dotnet/standard#567

We might have to add a target to Sentry package for net461 unfortunately.

@TimberToe

This comment has been minimized.

Copy link
Author

commented Nov 2, 2018

Thank you for looking into it =)

@bruno-garcia

This comment has been minimized.

Copy link
Member

commented Nov 2, 2018

@TimberToe thank you for reporting the issue!

Please let me know how your assessment of Sentry is going.
If you want to chat, I'm online on Sentry's .NET gitter channel:

https://gitter.im/getsentry/dotnet

@bruno-garcia

This comment has been minimized.

Copy link
Member

commented Jan 6, 2019

@TimberToe I've updated the sample with the latest version.
It worked with my tests but feel free to reopen if you encounter the issue again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.