Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update package.json #18

Closed
wants to merge 2 commits into from
Closed

Conversation

@patrick-fs
Copy link
Collaborator

patrick-fs commented Jan 14, 2020

Updating the FullStory version comparator to use a Caret range, in case a major version change would introduce a breaking change to the Sentry integration. Any major releases of @fullstorydev/browser will require and update to this package.json to use the latest version of the browser SDK.

Updating the FullStory version comparator to use a Caret range, in case a major version change would introduce a breaking change to the integration. Any major releases of `@fullstorydev/browser` will require and update to this integration `package.json` to use the latest version of the browser SDK.
@scefali

This comment has been minimized.

Copy link
Contributor

scefali commented Jan 14, 2020

@patrick-fs You should probably also make sure to run yarn so the yarn.lock file updates with the new version of the package.

EDIT: My bad, you didn't update the version of the FullStory SDK, ignore this comment :)

@patrick-fs

This comment has been minimized.

Copy link
Collaborator Author

patrick-fs commented Jan 15, 2020

Hey @scefali I'm going to give this a little more thought. I can see some downsides to locking the peer dep version of @fullstorydev/browser to ^2.0.0. I'm closing this PR for now but may revisit.

@patrick-fs patrick-fs closed this Jan 15, 2020
@patrick-fs patrick-fs deleted the patrick-fs/caret_range_comparitor branch Jan 15, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.