New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop support for Python 3.3 #997

Closed
jamadden opened this Issue Jul 20, 2017 · 1 comment

Comments

Projects
None yet
1 participant
@jamadden
Member

jamadden commented Jul 20, 2017

  • gevent version: 1.3.0
  • Python version: 3.3
  • Operating System: All

Python 3.3 has been in security-fix-only mode since 2014, with its final security fix release expected on August 7 and complete end-of-life expected in September of this year.

We should drop 3.3 support for gevent 1.3.0, which would tentatively be planned for the end of this year (based on historical release schedules where we try to have some release about every six months).

The immediate benefit will be faster build times (faster turnaround on Travis and when creating releases). There's also an inconsistency: we've never built Python 3.3 on Windows (Appveyor) or published 3.3 Windows wheels. Our README also says Python 3.4 is a requirement (although we still have the 3.3 classifier).

@jamadden

This comment has been minimized.

Member

jamadden commented Jul 20, 2017

It turns out we're already skipping the build under Python 3.3 on Travis.

@jamadden jamadden closed this in a873a8f Jul 21, 2017

jamadden added a commit that referenced this issue Jul 21, 2017

Merge pull request #1003 from gevent/997
Drop Python 3.3 remnants. Fixes #997.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment