Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on Jul 3, 2015
  1. minor cleanup

    authored
Commits on Jun 22, 2015
Commits on Jun 20, 2015
  1. readme changes

    authored
Commits on Jun 6, 2015
  1. 0.12.0

    authored
Commits on May 19, 2015
Commits on May 8, 2015
Commits on Apr 13, 2015
  1. update shellshape-local

    authored
  2. Merge branch '3.16'

    authored
  3. v0.11

    authored
Commits on Apr 10, 2015
  1. update README's hacking info

    authored
  2. Merge branch '3.16'

    authored
  3. 3.16

    authored
  4. fix whitespace

    authored
  5. @spacepluk

    add Gnome 3.16 fixes

    spacepluk authored committed
Commits on Apr 1, 2015
  1. 3.16

    authored
  2. fix whitespace

    authored
  3. Merge pull request #153 from spacepluk/gnome-3.16-fixes

    authored
    add Gnome 3.16 fixes
Commits on Mar 31, 2015
  1. @spacepluk

    add Gnome 3.16 fixes

    spacepluk authored
Commits on Mar 9, 2015
Commits on Feb 28, 2015
  1. @spacepluk
Commits on Feb 5, 2015
  1. minor fix to logging stub

    authored
Commits on Jan 30, 2015
  1. reinstated test suite

    authored
Commits on Jan 28, 2015
Commits on Nov 12, 2014
  1. Revert "workaround for typescript 1.1 incompatibility"

    authored
    This reverts commit 34bbe21.
  2. update local feed

    authored
  3. Merge pull request #147 from benalbrecht/patch-1

    authored
    workaround for typescript 1.1 incompatibility
  4. @benalbrecht

    workaround for typescript 1.1 incompatibility

    benalbrecht authored
    compilation fails with typescript 1.1 or higher with to the following error
    ```
    $ tools/gup compile
    gup  compile
    gup    schemas/inputs
    gup    shellshape/all
    gup      shellshape/extension.js
    gup        shellshape/_sources
    ../src/workspace.ts(434,10): error TS2365: Operator '===' cannot be applied to types 'Window' and 'Window'.
    gup      Target `shellshape/extension.js` failed with exit status 1
    gup    Target `shellshape/all` failed with exit status 2
    gup  Target `compile` failed with exit status 2
    ```
    this patch installs an older typescript version which works correctly
Commits on Sep 29, 2014
  1. declare 3.14 compatibility

    authored
Commits on Sep 21, 2014
Something went wrong with that request. Please try again.