New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SPWF04 will sometimes lose writes #14

Closed
Arke64 opened this Issue Sep 19, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@Arke64
Member

Arke64 commented Sep 19, 2018

The command executing will block waiting for the response that never comes. If you manually step in and resend the write header and payload, the device does respond and execution continues on. It happens more frequently if you send many commands with no wait between them.

https://community.st.com/thread/47453-spwf04sa-spi-send-race-condition maybe?
See also https://community.st.com/thread/45686-how-to-use-the-sockdw-command-correctly-over-spi-on-spwf04sa#comment-178223

Moved from ghi-electronics/TinyCLR-Libraries#170

@Arke64 Arke64 added the bug label Sep 19, 2018

@Arke64 Arke64 added this to the Backlog milestone Sep 19, 2018

@Arke64 Arke64 modified the milestones: Backlog, v1.0.0-preview3 Oct 4, 2018

@Arke64 Arke64 assigned Arke64 and unassigned Palomino34 Oct 18, 2018

@Arke64

This comment has been minimized.

Show comment
Hide comment
@Arke64

Arke64 Oct 18, 2018

Member

So we haven't observed this lately. The above commit does help when reading and may be related. In any case, closing for now.

Member

Arke64 commented Oct 18, 2018

So we haven't observed this lately. The above commit does help when reading and may be related. In any case, closing for now.

@Arke64 Arke64 closed this Oct 18, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment