New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

UC5550: OutputEnablePolarity wrong #315

Closed
Palomino34 opened this Issue Jun 28, 2018 · 0 comments

Comments

Projects
None yet
2 participants
@Palomino34
Contributor

Palomino34 commented Jun 28, 2018

From Aron:

On UC5550, the OutputEnablePolarity seems to have an opposite polarity than specified when the OutputEnableIsFixed is true. For the DE (data enable) pin, if OutputEnablePolarity is true, DE is low, and if OutputEnablePolarity is false, DE is high. An extension of this bug, When OutputEnableIsFixed is false, there is a signal on the DE pin. When OutputEnableIsFixed is changed to true and OutputEnabledPolarity is also true, there is still the same signal. When OutputEnableIsFixed stays true but OutputEnablePolarity is now false, the signal becomes high. When OutputEnableIsFixed is still true but OutputEnablePolarity is changed back to true, the signal becomes low.

@Palomino34 Palomino34 added the bug label Jun 28, 2018

@Palomino34 Palomino34 added this to the v1.0.0 milestone Jun 28, 2018

@Palomino34 Palomino34 self-assigned this Jun 28, 2018

@Arke64 Arke64 modified the milestones: v1.0.0, v1.0.0-preview1 Jun 28, 2018

@Arke64 Arke64 closed this in 58296c6 Aug 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment