New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Doesn't work with Nokogiri 1.5.1 #31

Closed
yannlugrin opened this Issue Mar 9, 2012 · 8 comments

Comments

Projects
None yet
5 participants
@yannlugrin
Copy link

yannlugrin commented Mar 9, 2012

Version 1.5 of Nokogiri isn't compatible witg google-spreadsheet-ruby:

Invalid expression: .//xmlns:link[@xmlns:@rel = 'http://schemas.google.com/spreadsheets/2006#cellsfeed'] (Nokogiri::XML::XPath::SyntaxError)

1.4.7 work fine.

@gimite

This comment has been minimized.

Copy link
Owner

gimite commented Mar 10, 2012

Thanks for the report. I'll take a look.

@gimite

This comment has been minimized.

Copy link
Owner

gimite commented Mar 11, 2012

I found that this is probably a bug in Nokogiri. I reported the bug and sent pull request:
https://github.com/tenderlove/nokogiri/pull/633

@gimite

This comment has been minimized.

Copy link
Owner

gimite commented Mar 12, 2012

This bug is in Nokogiri 1.5.1 and 1.5.2. Quick workaround for now is to use Nokogiri 1.5.0 or before.

@rstacruz

This comment has been minimized.

Copy link

rstacruz commented Mar 26, 2012

Awesome work on the spreadsheet gem and debugging Nokogiri, @gimite. :-)

@hagope

This comment has been minimized.

Copy link

hagope commented Mar 28, 2012

+1 for reverting to Nokogiri 1.5.0

@josh-m-sharpe

This comment has been minimized.

Copy link

josh-m-sharpe commented Apr 11, 2012

verified doesn't work with 1.5.2. rolled back to gem 'nokogiri' , '~> 1.4.0'

works now.

@gimite

This comment has been minimized.

Copy link
Owner

gimite commented Apr 14, 2012

Pushed google-spreadsheet-ruby 0.1.9 which excludes nokogiri 1.5.1 and 1.5.2 from dependency. So if you update google-spreadsheet-ruby, it should automatically use nokogiri 1.5.0 or before for now.

@gimite gimite closed this Apr 14, 2012

@gimite

This comment has been minimized.

Copy link
Owner

gimite commented Apr 14, 2012

I found google-spreadsheet-ruby 0.1.9 is broken. Please use 0.2.1. Sorry for confusion.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment