hi thanks for helping a rails newbie. All i've done is add gem 'social_stream', '>= 1.0.0' to my gemfile and now i'm trying to install everything. I've already got devise-2.2.3 as part of a different demo i did. Will I have to downgrade my devise gem?
Fetching gem metadata from https://rubygems.org/.........
Fetching gem metadata from https://rubygems.org/..
Bundler could not find compatible versions for gem "devise":
social_stream (>= 1.0.0) ruby depends on
devise (~> 2.1.2) ruby
You should just have to do
gem update devise
really? i thought the problem was that social stream is dependent on an old version of devise. how would trying to update devise, which is already up to date, going to fix my issue?
Social stream depends on Devise 2.1.2 indeed. You will need to downgrade you Devise version. You are also welcomed to send us a pull request with the new version and the required fixes.
This is fixed in master and will be released with Social Stream 2.0