Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Rails 3 compatibility #6

merged 1 commit into from

2 participants


Hi there. This is a fix for the deprecated require 'activesupport', replacing it with
active_support to make it compatible with Rails 3, and adding /all which is necessary to include cattr_accessor).


Thanks Graham.

@gingerhendrix gingerhendrix merged commit 0c457eb into gingerhendrix:master

You're welcome - when I saw that my fork fixed exactly the same bug as about 7 others I figured someone ought to send you a pull request!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 25, 2012
  1. @grahamsnyder
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  lib/scrobbler2.rb
2  lib/scrobbler2.rb
@@ -1,5 +1,5 @@
require 'rubygems'
-require 'activesupport'
+require 'active_support/all'
require 'httparty'
$: << File.dirname(__FILE__)
Something went wrong with that request. Please try again.