A webpack loader for the wisp language
JavaScript
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
.gitignore
README.md
index.js
package.json

README.md

wisp loader for webpack

Allows for compilation and requiring of wisp files via webpack

Usage

Documentation: Using loaders

Install the loader for your project

npm install -D wisp-loader

Require a wisp file in your Javascript code, or set a wisp file as your entry in your webpack config.

var ex = require('./example.wisp');

Example webpack config

module.exports = {
    entry: './src/index.wisp',

    output: {
        path: __dirname,
        filename: 'bundle.js'
    },

    module: {
        loaders: [
            {
                test: /\.wisp$/,
                loader: 'wisp-loader'
            }
        ]
    },
};

Changelog

0.2.0

  • Merged PR #1 from @thatismatt, which passes through webpack query strings/objects through to the wisp compiler

0.1.3

  • Removed unneeded string munging of require() calls
  • Pushes '.wisp' onto the resolve.extensions array to enable require() calls to work correctly
  • Added proper error handling, so failed compilations don't crash the webpack-dev-server

0.1.2

  • Moved wisp dependency to a proper peerDependencies block
  • Performance tested vs transform-loader with wispify, basically identical in compilation time with a micro-benchmark

0.1.1

  • Fixed up the npm publish
  • Tested more of the loader

0.1.0

  • Initial release, stuffed up the npm publish

License

MIT