Skip to content
Permalink
Branch: master
Commits on Nov 9, 2018
  1. http: add support selecting http version

    fcharlie authored and gitster committed Nov 9, 2018
    Usually we don't need to set libcurl to choose which version of the
    HTTP protocol to use to communicate with a server.
    But different versions of libcurl, the default value is not the same.
    
    CURL >= 7.62.0: CURL_HTTP_VERSION_2TLS
    CURL < 7.62: CURL_HTTP_VERSION_1_1
    
    In order to give users the freedom to control the HTTP version,
    we need to add a setting to choose which HTTP version to use.
    
    Signed-off-by: Force Charlie <charlieio@outlook.com>
    Signed-off-by: Junio C Hamano <gitster@pobox.com>
You can’t perform that action at this time.