New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bare repositories appear as (empty) and are not clickable #309

Closed
gitblit opened this Issue Aug 12, 2015 · 3 comments

Comments

Projects
None yet
2 participants
@gitblit
Owner

gitblit commented Aug 12, 2015

Originally reported on Google Code with ID 13

Environment: gitblit-0.5.1 GO, OS X, Java 6

"What steps will reproduce the problem?"
1. Clone a repository from somewhere as bare into the configured git.repositoriesFolder

 for example git clone --bare git://github.com/tfnico/guava-examples.git
2. Refresh the list of repositories in Gitblit - watch the new repo appears
3. Observe the repo appears (empty)

"What is the expected output? What do you see instead?"

If I clone the repo without the --bare parameter, it appears as a normal repo. I can
click it and browse it.

Reported by tfnico on 2011-07-20 15:30:44

@gitblit gitblit self-assigned this Aug 12, 2015

@gitblit

This comment has been minimized.

Owner

gitblit commented Aug 12, 2015

Ok.  I didn't test bare clones so my check for an empty repository fails in that scenario.

Reported by James.Moger on 2011-07-20 15:57:47

  • Status changed: Accepted
@gitblit

This comment has been minimized.

Owner

gitblit commented Aug 12, 2015

Reported by James.Moger on 2011-07-21 18:54:40

  • Labels added: Milestone-0.5.2
@gitblit

This comment has been minimized.

Owner

gitblit commented Aug 12, 2015

Reported by James.Moger on 2011-07-27 12:14:27

  • Status changed: Fixed

@gitblit gitblit closed this Aug 12, 2015

@fzs fzs modified the milestone: 0.5.2 Dec 12, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment