Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Install location and/or git.repositoriesFolder symlinks cause trouble on push #374

Closed
gitblit opened this issue Aug 12, 2015 · 7 comments
Closed

Comments

@gitblit
Copy link
Owner

@gitblit gitblit commented Aug 12, 2015

Originally reported on Google Code with ID 78

Hi,

Using version 0.9.1. Worked in 0.7.0.

I'm getting this exception when pushing changes to GitBlit repository and the push
fails.
There are no hooks configured in gitblit.properties. 
/srv/git is where my git repositories are located.

ERROR GitBlit.getRepository(String) failed to find /srv/git/tdaemon/test
WARN  Internal error during receive-pack
java.lang.NullPointerException
        at com.gitblit.GitServlet$GitblitReceiveHook.onPreReceive(GitServlet.java:166)
        at org.eclipse.jgit.transport.ReceivePack.executeCommands(ReceivePack.java:1047)
        at org.eclipse.jgit.transport.ReceivePack.service(ReceivePack.java:697)
        at org.eclipse.jgit.transport.ReceivePack.receive(ReceivePack.java:617)

Reported by andrejs.jermakovics on 2012-03-28 14:00:03

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

I'm not sure where tdaemon/test came from but when I created it pushes started working

Reported by andrejs.jermakovics on 2012-03-28 14:14:50

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Is your git.repositoriesFolder a symlink?

Reported by James.Moger on 2012-03-28 14:34:07

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

I'm pretty certain either your entire Gitblit install is in a symlinked folder or your
git.repositoriesFolder points to a symlinked folder.

There appears to be a discrepancy between Gitblit and JGit in the use of canonical
and absolute paths wrt symlinks.  I'll try to create a unit test to confirm this.

Reported by James.Moger on 2012-03-28 15:58:40

  • Status changed: Accepted

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

gitblit install is in a symlinked folder. git.repositoriesFolder is not symlinked but
all the repos inside it are symlinked.


Reported by andrejs.jermakovics on 2012-03-28 20:03:20

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Reported by James.Moger on 2012-03-28 21:01:04

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

I've confirmed this is a absolute path vs. canonical path issue between Gitblit and
JGit.  I've fixed this on master.  I'm going to let this sit for a little while to
see what other bugs pop-up.  I will probably release an 0.9.2 build for this bug.

Reported by James.Moger on 2012-03-28 22:01:50

  • Status changed: Queued
  • Labels added: Milestone-0.9.2

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Fix deployed in v0.9.2.

Reported by James.Moger on 2012-04-04 14:19:29

  • Status changed: Fixed

@gitblit gitblit closed this as completed Aug 12, 2015
@flaix flaix added this to the 0.9.2 milestone Dec 13, 2016
@flaix flaix added this to the 0.9.2 milestone Dec 13, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants