New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No repaint in main dialog after MalformedURLException #423

Closed
gitblit opened this Issue Aug 12, 2015 · 4 comments

Comments

Projects
None yet
1 participant
@gitblit
Owner

gitblit commented Aug 12, 2015

Originally reported on Google Code with ID 127

I'm trying to connect to my company's Git repo. I have the URL, and I don't believe
it needs a username/password since its available internally (I could be wrong, but
I have not gotten that far).

When I select the repo and try to connect, I get an exception:

java.util.concurrent.ExecutionException: java.net.MalformedURLException: no protocol:
suvi.example.com/mobile-security/irat.git

I have also tried specifying git://suvi.example.com/mobile-security/irat.git.

After dismissing the exception dialog, I am left with an empty main dialog (see attached).

For the inital problem - MalformedURLException - I'm not sure what the problem is.
I believe the URL is correct since someone else provided it copy/paste..

Perhaps it would be a good idea to cath the exception and provide a more meaningful
error message. After displaying the message, it would definetly be a good idea to repaint
the main dialog.

Reported by noloader on 2012-09-05 20:53:48


- _Attachment: gitblit-mamanger-needs-painting.png
![gitblit-mamanger-needs-painting.png](https://storage.googleapis.com/google-code-attachments/gitblit/issue-127/comment-0/gitblit-mamanger-needs-painting.png)_
@gitblit

This comment has been minimized.

Show comment
Hide comment
@gitblit

gitblit Aug 12, 2015

Owner
The problem occurs on Windows 7 Professional, x64 (fully patched) with Java 7.

C:\Users\jwalton\>java -version
java version "1.7.0_07"
Java(TM) SE Runtime Environment (build 1.7.0_07-b10)
Java HotSpot(TM) 64-Bit Server VM (build 23.3-b01, mixed mode)

Reported by noloader on 2012-09-05 20:55:58

Owner

gitblit commented Aug 12, 2015

The problem occurs on Windows 7 Professional, x64 (fully patched) with Java 7.

C:\Users\jwalton\>java -version
java version "1.7.0_07"
Java(TM) SE Runtime Environment (build 1.7.0_07-b10)
Java HotSpot(TM) 64-Bit Server VM (build 23.3-b01, mixed mode)

Reported by noloader on 2012-09-05 20:55:58

@gitblit

This comment has been minimized.

Show comment
Hide comment
@gitblit

gitblit Aug 12, 2015

Owner
Problem 1. You did not specify a protocol.  And when you did you specified the git://
protocol.  This must be http:// or https://

Problem 2. You are specifying an exact repository.  The Gitblit manager is designed
to communicate over http with a Gitblit server, not a Git repository.

You should specify the root url of your Gitblit server - the same URL you browse the
repository list.  e.g. https://suvi.example.com or http://localhost:8080/gitblit or
something like that.

Reported by James.Moger on 2012-09-05 21:10:31

Owner

gitblit commented Aug 12, 2015

Problem 1. You did not specify a protocol.  And when you did you specified the git://
protocol.  This must be http:// or https://

Problem 2. You are specifying an exact repository.  The Gitblit manager is designed
to communicate over http with a Gitblit server, not a Git repository.

You should specify the root url of your Gitblit server - the same URL you browse the
repository list.  e.g. https://suvi.example.com or http://localhost:8080/gitblit or
something like that.

Reported by James.Moger on 2012-09-05 21:10:31

@gitblit

This comment has been minimized.

Show comment
Hide comment
@gitblit

gitblit Aug 12, 2015

Owner
Have you been able to get the Manager working?

Reported by James.Moger on 2012-09-06 17:09:11

Owner

gitblit commented Aug 12, 2015

Have you been able to get the Manager working?

Reported by James.Moger on 2012-09-06 17:09:11

@gitblit

This comment has been minimized.

Show comment
Hide comment
@gitblit

gitblit Aug 12, 2015

Owner
Since I have not heard a response, I will assume that the url information in my comments
resolved your issue.

Reported by James.Moger on 2012-09-10 13:02:26

  • Status changed: WontFix
Owner

gitblit commented Aug 12, 2015

Since I have not heard a response, I will assume that the url information in my comments
resolved your issue.

Reported by James.Moger on 2012-09-10 13:02:26

  • Status changed: WontFix

@gitblit gitblit closed this Aug 12, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment