Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

/etc/init.d/gitblit: 8: /etc/init.d/gitblit: source: not found #450

Closed
gitblit opened this issue Aug 12, 2015 · 7 comments
Closed

/etc/init.d/gitblit: 8: /etc/init.d/gitblit: source: not found #450

gitblit opened this issue Aug 12, 2015 · 7 comments

Comments

@gitblit
Copy link
Owner

@gitblit gitblit commented Aug 12, 2015

Originally reported on Google Code with ID 154

What steps will reproduce the problem?
1.Download and extract GitBlit
2.run install-service.sh
3.start service with /etc/ini.d/gitblit start

What is the expected output? What do you see instead?

I expect: 

[ ok ] Starting gitblit server...done.

But shows:

/etc/init.d/gitblit: 8: /etc/init.d/gitblit: source: not found

What version of the product are you using? On what operating system?

Gitblit GO 1.1.0

Please provide any additional information below.

removing "source" from that script, service start without problem

Reported by yeradis on 2012-10-26 20:36:18

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

btw I'm using Linux Mint Debian Edition.... 

"source" command works , but inside that ini.d script doesnt :(

Reported by yeradis on 2012-10-27 20:41:14

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

That line tries to include/exec another shell script.  That script is not set executable.
 Perhaps if you chmod +x that target script it would work.  There is also a gitblit-ubuntu
variant which is not used by install-service.sh.  This one perhaps may work better.

Reported by James.Moger on 2012-10-28 12:54:50

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

It still happens on 1.2.1 and my solution is modifying first line of the /etc/init.d/gitblit
as follows:

BEFORE
#!/bin/sh
AFTER
#!/bin/bash

Environment:
sakurai@WIX:/opt/gitblit$ uname -a
Linux WIX 3.2.0-4-amd64 #1 SMP Debian 3.2.39-2 x86_64 GNU/Linux

How to:
sudo apt-get install openjdk-6-jre-headless
sudo mkdir /opt/gitblit
cd /tmp
wget https://gitblit.googlecode.com/files/gitblit-1.2.1.zip
cd /opt/gitblit
sudo unzip /tmp/gitblit-1.2.1.zip

sudo vi data/gitblit.properties
# web.enableRpcServlet=true
# web.enableRpcManagement=true
# web.enableRpcAdministration=true

sudo sh install-service.sh
sudo /etc/init.d/gitblit start


Reported by sakurai.youhei on 2013-04-10 08:42:38

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

The scripts in master have been updated to always use bash instead of sh.

Reported by James.Moger on 2013-04-10 12:07:26

  • Status changed: Queued
  • Labels added: Milestone-1.3.0

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Change the line:
From: source ${GITBLIT_PATH}/java-proxy-config.sh
From: . ${GITBLIT_PATH}/java-proxy-config.sh

Use a . (dot or single point) instead source


Reported by josivanps on 2013-07-12 02:38:33

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

I believe one is an alias for the other.

  i.e. source == .

So I'm not sure this would change anything.

Reported by James.Moger on 2013-07-12 11:58:58

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Fix or enhancement released in v1.3.0

Reported by James.Moger on 2013-07-14 16:52:58

  • Status changed: Fixed

@gitblit gitblit closed this as completed Aug 12, 2015
@flaix flaix added this to the 1.3.0 milestone Dec 13, 2016
@flaix flaix added this to the 1.3.0 milestone Dec 13, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants