Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Owners can not be modified when the owners in the config file do not exist #776

Closed
gitblit opened this issue Aug 12, 2015 · 5 comments
Closed

Comments

@gitblit
Copy link
Owner

@gitblit gitblit commented Aug 12, 2015

Originally reported on Google Code with ID 480

I recently imported a lot of git repositories from another gitblit server. I figured
the quickest way to do this would be to just rsync the repo's over to the new server.
I realise I could have set up a federation etc, but due to connectivity issues, rsync
was a lot easier.

However some repositories have owners which do not exist in the new gitblit installation.
The admin user is not able to modify them, I can only fix it by editing the config
file.

What steps will reproduce the problem?
1. Create a git(blit) repo on gitblit server 1, with owner "FOO"
2. Copy the git folder over to gitblit server 2 (rsync), not having a user named "FOO"

What is the expected output? What do you see instead?
I expect gitblit to either delete unknown users automatically from the list, or display
them anyway for me to manually remote them in the repository page. I see an 2 empty
lists, and i'm not able to change any owner, not even existing ones. See the attached
screenshot.

What version of the product are you using? On what operating system?
Current latest gitblit master (3e0c6ca8a65bd4b076cac1451c9cdfde4be1d4b8), on Ubuntu
14.04 running Tomcat 7 and OpenJDK (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1) 64 bit.

Please provide any additional information below.
I solved the issue by manually editing the config files in the repositories. I have
"basic auth" enabled rather than form based auth.

Reported by robindegen on 2014-08-05 16:15:11


- _Attachment: empty list.png
![empty list.png](https://storage.googleapis.com/google-code-attachments/gitblit/issue-480/comment-0/empty list.png)_
@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

I should note that these repo's came from a gitblit 1.4 server. I could trace back the
exact version if required.

Reported by robindegen on 2014-08-05 16:16:28

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Reported by James.Moger on 2014-08-12 18:08:45

  • Status changed: Accepted
  • Labels added: Milestone-1.6.1

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

I could not reproduce your exact symptoms: I had a list of potential owners to choose
from. But I do confirm that your missing owner was not displayed.  I have pushed a
fix to display & preserve your missing owner.

Reported by James.Moger on 2014-09-04 17:50:39

  • Status changed: Queued

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

Tested on v1.6.0-116-gfbe6dbd, the problem is now fixable through the webinterface,
so i'd consider this one fixed. Thanks

Reported by robindegen on 2014-09-26 09:24:31

@gitblit
Copy link
Owner Author

@gitblit gitblit commented Aug 12, 2015

v1.6.1 released

Reported by James.Moger on 2014-10-20 21:36:03

  • Status changed: Done

@gitblit gitblit closed this as completed Aug 12, 2015
@flaix flaix added this to the 1.6.1 milestone Dec 13, 2016
@flaix flaix added this to the 1.6.1 milestone Dec 13, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants