Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Viewing a mirrored repo of certain repositories causes Internal Error #782

Closed
gitblit opened this issue Aug 12, 2015 · 4 comments
Closed

Comments

@gitblit
Copy link
Owner

gitblit commented Aug 12, 2015

Originally reported on Google Code with ID 486

What steps will reproduce the problem?
1. Create a mirror clone of: 
https://github.com/MinecraftForge/MinecraftForge.git
2. Browse to this repository through gitblit 
3. This will display an internal server error (UnsupportedCharsetException)

What is the expected output? What do you see instead?
The expected output would be the same as all the other repositories. It displays an
Internal Error.

What version of the product are you using? On what operating system?
Gitblit GO, git rev 3e0c6ca8a65bd4b076cac1451c9cdfde4be1d4b8

Please provide any additional information below.
Using Ubuntu 64-bit, Oracle Java 1.7.0_67. I've attached the log file of the exception.


Reported by robindegen on 2014-08-19 12:38:12


- _Attachment: [gitblit_log.txt](https://storage.googleapis.com/google-code-attachments/gitblit/issue-486/comment-0/gitblit_log.txt)_
@gitblit
Copy link
Owner Author

gitblit commented Aug 12, 2015

Gitblit won't even startup with that repo.  Same reason: unknown charset utf-18.

https://en.wikipedia.org/wiki/UTF-9_and_UTF-18

I've pushed a fix that will inject an UTF-8 alias for both fake encodings into JGit's
charset alias map/dictionary.  Unfortunately that map is private so I had to use reflection
to inject the aliases.

That repo now loads and is browseable.

Reported by James.Moger on 2014-09-04 18:24:48

  • Status changed: Queued
  • Labels added: Milestone-1.6.1

@gitblit
Copy link
Owner Author

gitblit commented Aug 12, 2015

Thank you, I will test this in the weekend and let you know if it works for the other
repo's I had similar issues with

Reported by robindegen on 2014-09-04 18:27:11

@gitblit
Copy link
Owner Author

gitblit commented Aug 12, 2015

Sorry for the extreme delay. I've managed to test this on v1.6.0-116-gfbe6dbd, and it
works perfectly. Thanks!

Reported by robindegen on 2014-09-25 18:01:50

@gitblit
Copy link
Owner Author

gitblit commented Aug 12, 2015

v1.6.1 released

Reported by James.Moger on 2014-10-20 21:36:03

  • Status changed: Done

@gitblit gitblit closed this as completed Aug 12, 2015
@flaix flaix modified the milestone: 1.6.1 Dec 13, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants