New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

PuTTY Installer Is Outdated #4509

Closed
MrScruffy04 opened this Issue Feb 22, 2018 · 23 comments

Comments

Projects
None yet
@MrScruffy04

MrScruffy04 commented Feb 22, 2018

By default, GitExtensions allows you to install PuTTY 0.63. Until today (2018-02-22) that was fine for connecting to github. However, due to github discontinuing weak crypto support (https://githubengineering.com/crypto-removal-notice/), PuTTY 0.63 is insufficient.

When I attempted a push, the error message github returned started with FATAL ERROR: Couldn't agree a key exchange algorithm

As a workaround for now, I was able to:

  1. Download the latest PuTTY at https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
  2. Install PuTTY to the default directory
  3. Copy/replace the four PuTTY .exe's in the GitExtensions install directory: pageant.exe, plink.exe, putty.exe, and puttygen.exe

I experienced this on a Windows 7, 32-bit VM where I had not previously installed PuTTY independent of GitExtensions. I was using GitExtensions 2.51 (latest release at the time). The standalone version of PuTTY I installed was 0.70.

@gerhardol

This comment has been minimized.

Contributor

gerhardol commented Feb 22, 2018

The PuTTY version has an update in #4470 that should be merged soon, just some testing that is missing. Please chime in on the PR if you have tested this.

I guess this is a candidate for a 2.51 update release too

@gerhardol gerhardol added the type: bug label Feb 22, 2018

@gerhardol gerhardol added this to the 2.51.x + 3.00 milestone Feb 22, 2018

@grantaholliday

This comment has been minimized.

grantaholliday commented Feb 22, 2018

Are you able to also bump the packaged version of Git for Windows from 2.13.2 to the latest 2.16.2, as it includes Git Credential Manager for Windows, which includes TLS 1.2 support?

@gerhardol

This comment has been minimized.

Contributor

gerhardol commented Feb 22, 2018

Are you able to also bump the packaged version of Git for Windows from 2.13.2 to the latest 2.16.2

2.16.1 is in latest master, right now not targeted for next 2.51 update but for next version (may be 3.0)
Git should be updated to latest next "stable" version, at least in next release.
However, I propose that Git is updated separately from GE

@RussKie

This comment has been minimized.

Member

RussKie commented Feb 23, 2018

@RussKie

This comment has been minimized.

Member

RussKie commented Feb 23, 2018

@golddragon007

This comment has been minimized.

golddragon007 commented Feb 23, 2018

Currently I needed to update PUTTY manually, because I get this error:
FATAL ERROR: Couldn't agree a key exchange algorithm (available: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521)
fatal: Could not read from remote repository.
For every github repos. (updated to 0.7 and now it works)

@EbenZhang

This comment has been minimized.

Contributor

EbenZhang commented Feb 23, 2018

@golddragon007

This comment has been minimized.

golddragon007 commented Feb 23, 2018

I just updated the putty and works...

@sahgilbert

This comment has been minimized.

sahgilbert commented Feb 23, 2018

I followed the update steps above and it resolved the issue.

@MarcoWilliamsPF

This comment has been minimized.

MarcoWilliamsPF commented Feb 26, 2018

I think this is still an issue with Putty x64 .. I am at the latest version of Git & latest version of Putty and I'm getting the same error message.

@RussKie

This comment has been minimized.

Member

RussKie commented Feb 26, 2018

Have you updated git to 2.16+?

@RussKie

This comment has been minimized.

Member

RussKie commented Feb 26, 2018

Relates to #4523

@MarcoWilliamsPF

This comment has been minimized.

MarcoWilliamsPF commented Feb 26, 2018

yes, my git version is 2.16.2.windows.1, and I have no idea how to get this working again.

@RussKie

This comment has been minimized.

Member

RussKie commented Feb 26, 2018

Can it be related to #4011?

@MarcoWilliamsPF

This comment has been minimized.

MarcoWilliamsPF commented Feb 26, 2018

reading and checking now.

@MarcoWilliamsPF

This comment has been minimized.

MarcoWilliamsPF commented Feb 26, 2018

okay, so that did work in the end.. but setting the values in RegEdit didn't work alone.. I had to set the values in RegEdit + GitExtensions --> Settings --> SSH and update the paths in both places (AND CLICK APPLY or it doesn't set it) .. Now it's working! Thanks for the help @RussKie !

@DLoBoston

This comment has been minimized.

DLoBoston commented Feb 27, 2018

@MarcoWilliamsPF - this last post saved my tush today. Thank you!

@cinnaman

This comment has been minimized.

cinnaman commented Mar 13, 2018

Fix steps proposed by @MrScruffy04 works with Git Extensions v2.51 on a Windows 7 machine. Only updated my PuTTy .EXEs and no need for Git version update from the one that shipped with Git Extensions package. Thanks!

@kelteseth

This comment has been minimized.

kelteseth commented Mar 14, 2018

@cinnaman this worked for me too:

  1. Downloading https://the.earth.li/~sgtatham/putty/latest/w64/putty.zip
  2. Extracting into: C:\Program Files (x86)\GitExtensions\PuTTY
@vbjay

This comment has been minimized.

Contributor

vbjay commented Mar 14, 2018

@vbjay

This comment has been minimized.

Contributor

vbjay commented Mar 14, 2018

@RussKie

This comment has been minimized.

Member

RussKie commented Mar 14, 2018

@dwolsey

This comment has been minimized.

dwolsey commented Mar 19, 2018

Thank you, I changed to using openSSH option in Git Extensions (v2.51) which fixed the error I was getting.

Tools -> Settings -> SSH -> Select OpenSSH

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment