New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Stuck at Two-Step Authentication #176

Closed
haider-kazal opened this Issue Dec 23, 2015 · 11 comments

Comments

Projects
None yet
7 participants
@haider-kazal

After updating the extension to the latest, it gets stuck after I give the token. Tried in 4 pcs, happens in all of them.

image

@shana

This comment has been minimized.

Show comment
Hide comment
@shana

shana Dec 28, 2015

Collaborator

There's nothing in the latest release that would affect the login, so not sure what's going on here. If it's still happening, you can try uninstalling the extension and installing earlier releases from the releases page at https://github.com/github/VisualStudio/releases, to see if you can find one that works (and where it broke)

Collaborator

shana commented Dec 28, 2015

There's nothing in the latest release that would affect the login, so not sure what's going on here. If it's still happening, you can try uninstalling the extension and installing earlier releases from the releases page at https://github.com/github/VisualStudio/releases, to see if you can find one that works (and where it broke)

@haider-kazal

This comment has been minimized.

Show comment
Hide comment
@haider-kazal

haider-kazal Dec 28, 2015

Ok... Thanks, I'll roll back to previous version then.

Date: Mon, 28 Dec 2015 02:40:42 -0800
From: notifications@github.com
To: VisualStudio@noreply.github.com
CC: haider_kazal@hotmail.com
Subject: Re: [VisualStudio] Stuck at Two-Step Authentication (#176)

There's nothing in the latest release that would affect the login, so not sure what's going on here. If it's still happening, you can try uninstalling the extension and installing earlier releases from the releases page at https://github.com/github/VisualStudio/releases, to see if you can find one that works (and where it broke)


Reply to this email directly or view it on GitHub.

Ok... Thanks, I'll roll back to previous version then.

Date: Mon, 28 Dec 2015 02:40:42 -0800
From: notifications@github.com
To: VisualStudio@noreply.github.com
CC: haider_kazal@hotmail.com
Subject: Re: [VisualStudio] Stuck at Two-Step Authentication (#176)

There's nothing in the latest release that would affect the login, so not sure what's going on here. If it's still happening, you can try uninstalling the extension and installing earlier releases from the releases page at https://github.com/github/VisualStudio/releases, to see if you can find one that works (and where it broke)


Reply to this email directly or view it on GitHub.

@anthonychu

This comment has been minimized.

Show comment
Hide comment
@anthonychu

anthonychu Jan 3, 2016

This happened to me on 2 separate VS2015 installs as well. As we can see in the screenshot above, the login is actually completed (GitHub repos are showing in Team Explorer). But the modal stays open with the "Verify" spinner going forever. Closing the modal manually by clicking the X seems to work fine.

This happened to me on 2 separate VS2015 installs as well. As we can see in the screenshot above, the login is actually completed (GitHub repos are showing in Team Explorer). But the modal stays open with the "Verify" spinner going forever. Closing the modal manually by clicking the X seems to work fine.

@Haacked

This comment has been minimized.

Show comment
Hide comment
@Haacked

Haacked Jan 3, 2016

Member

I think I know what this bug is. It's tricky. I can look into it later.

Member

Haacked commented Jan 3, 2016

I think I know what this bug is. It's tricky. I can look into it later.

@haider-kazal

This comment has been minimized.

Show comment
Hide comment
@haider-kazal

haider-kazal Jan 4, 2016

Thanks everyone... And another thing, I get logged out each time I close Visual Studio after these bug occured... Please look onto tha too... Thanks

Thanks everyone... And another thing, I get logged out each time I close Visual Studio after these bug occured... Please look onto tha too... Thanks

@timsneath

This comment has been minimized.

Show comment
Hide comment
@timsneath

timsneath Jan 5, 2016

Getting the same issue here with Visual Studio 2015 Update 1, although as @anthonychu says, you can close the dialog box and everything still seems to work.

Getting the same issue here with Visual Studio 2015 Update 1, although as @anthonychu says, you can close the dialog box and everything still seems to work.

@WillBuik

This comment has been minimized.

Show comment
Hide comment
@WillBuik

WillBuik Jan 7, 2016

Running into this as well on VS 2015 Update 1. Manually closing the dialog worked around the issue for me.

WillBuik commented Jan 7, 2016

Running into this as well on VS 2015 Update 1. Manually closing the dialog worked around the issue for me.

@jakenuts

This comment has been minimized.

Show comment
Hide comment
@jakenuts

jakenuts Jan 12, 2016

I found a solution from several articles on the subject, though this one had the right combination (for me). In short, you generate a Personal Access Token in GitHub and when the authentication window appears enter your GitHub username and the token as your password. I haven't seen the dialog since.

I found a solution from several articles on the subject, though this one had the right combination (for me). In short, you generate a Personal Access Token in GitHub and when the authentication window appears enter your GitHub username and the token as your password. I haven't seen the dialog since.

@shana

This comment has been minimized.

Show comment
Hide comment
@shana

shana Jan 12, 2016

Collaborator

Thanks for the reports everyone. We're working on this, it feels like the dialog just isn't closing properly even though it completes the authentication successfully (but not every time, so it's annoying to debug).

@jakenuts The authentication dialog already handles 2FA, so using personal tokens is not the solution to this particular issue.

Collaborator

shana commented Jan 12, 2016

Thanks for the reports everyone. We're working on this, it feels like the dialog just isn't closing properly even though it completes the authentication successfully (but not every time, so it's annoying to debug).

@jakenuts The authentication dialog already handles 2FA, so using personal tokens is not the solution to this particular issue.

shana added a commit that referenced this issue Jan 12, 2016

@Haacked Haacked closed this in #193 Jan 12, 2016

@shana shana reopened this Jan 15, 2016

@shana

This comment has been minimized.

Show comment
Hide comment
@shana

shana Jan 15, 2016

Collaborator

Hey everyone!

#202 is the reason why some of you keep getting logged out. I'll get a new release out asap to fix that as well as the login dialog not going away, will let you know when it's out.

Collaborator

shana commented Jan 15, 2016

Hey everyone!

#202 is the reason why some of you keep getting logged out. I'll get a new release out asap to fix that as well as the login dialog not going away, will let you know when it's out.

@shana shana added the bug label Jan 18, 2016

@shana shana modified the milestone: 1.0.16.4 - Bug fixes Jan 18, 2016

@shana shana closed this Jan 19, 2016

@shana

This comment has been minimized.

Show comment
Hide comment
@shana

shana Jan 19, 2016

Collaborator

Hi again!

I just published a beta that includes a fix for this - v1.0.16.3. It's still undergoing testing, but if you want to try it out, you can configure a gallery in Visual Studio to get access to beta, current and older versions of the extension. You can also download the beta from the releases page.

To configure the beta gallery, go to Tools / Options / Extensions and Updates and add a new gallery with the url https://visualstudio.github.com/releases/feed.rss. You'll be able to access it in Tools / Extensions and Updates in the Online or Updates tab, and you'll be able to install the beta version (or older versions, if you want).

Collaborator

shana commented Jan 19, 2016

Hi again!

I just published a beta that includes a fix for this - v1.0.16.3. It's still undergoing testing, but if you want to try it out, you can configure a gallery in Visual Studio to get access to beta, current and older versions of the extension. You can also download the beta from the releases page.

To configure the beta gallery, go to Tools / Options / Extensions and Updates and add a new gallery with the url https://visualstudio.github.com/releases/feed.rss. You'll be able to access it in Tools / Extensions and Updates in the Online or Updates tab, and you'll be able to install the beta version (or older versions, if you want).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment