New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Visual Studio crashes when publishing new repository #275

Closed
mponce1 opened this Issue Apr 29, 2016 · 1 comment

Comments

Projects
None yet
3 participants
@mponce1
Contributor

mponce1 commented Apr 29, 2016

Steps to reproduce:

  1. Sign into GH via manage connections
  2. Create new local repository
  3. Double click and go to Sync
  4. Click publish to github and follow prompts

Expected result: New repository pushed to .com and remote is set.
Actual result: VS crashes.

Stacktrace: https://gist.github.com/MergeCity/e91eea9f8c2764d3d19a185bcb60f7fa

shana added a commit that referenced this issue Apr 30, 2016

Fix all the bindings
A bunch of classes were doing xaml bindings in a very wrong way, relying
on some external code setting the ViewModel property explicitly and not
defining the bindings in xaml.
Make every SimpleUserControl subclass set the ViewModel property via the
DataContextChanged event (DataContext is set for every view in
UIController), and fix the xaml bindings so things work.
Remove useless ReactiveUI code-behind bindings while we're at it, it's
pointless doing it twice.

This should fix #274 and #275

@shana shana added verified and removed bug labels May 2, 2016

@mponce1 mponce1 closed this May 3, 2016

@Baneeishaque

This comment has been minimized.

Show comment
Hide comment
@Baneeishaque

Baneeishaque Apr 19, 2018

is the bug resolved - and in which version of vs 2017?

is the bug resolved - and in which version of vs 2017?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment