New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Corrupted usage data is causing the extension to not load properly #516

Closed
shana opened this Issue Aug 23, 2016 · 5 comments

Comments

Projects
None yet
2 participants
@shana
Collaborator

shana commented Aug 23, 2016

The last couple of days I get this error when starting Visual Studio:
The 'GitHubPackage' package did not load correctly.....

I re-installed the package, but that did not help.

The activity log of Visual Studio says the following: (any idea what the json error is?)

 <activity>
   <!-- ... -->
   <entry>
     <record>129</record>
     <time>2016/08/23 08:38:06.350</time>
     <type>Information</type>
     <source>VisualStudio</source>
     <description>Begin package load [GitHubPackage]</description>
     <guid>{C3D3DC68-C977-411F-B3E8-03B0DCCF7DFC}</guid>
   </entry>
   <entry>
     <record>130</record>
     <time>2016/08/23 08:38:06.525</time>
     <type>Error</type>
     <source>VisualStudio</source>
     <description>LegacySitePackage failed for package [GitHubPackage]Source: &apos;GitHub.Exports&apos; Description: Invalid JSON string
     System.Runtime.Serialization.SerializationException: Invalid JSON string
        at GitHub.SimpleJson.DeserializeObject(String json) in Y:\jenkins\workspace\GitHub for Visual Studio speakeasy jenkinskeep\src\GitHub.Exports\SimpleJson.cs:line 544
        at GitHub.SimpleJson.DeserializeObject(String json, Type type, IJsonSerializerStrategy jsonSerializerStrategy) in Y:\jenkins\workspace\GitHub for Visual Studio speakeasy jenkinskeep\src\GitHub.Exports\SimpleJson.cs:line 577
        at GitHub.SimpleJson.DeserializeObject[T](String json) in Y:\jenkins\workspace\GitHub for Visual Studio speakeasy jenkinskeep\src\GitHub.Exports\SimpleJson.cs:line 595
        at GitHub.Services.UsageTracker.LoadUsage() in Y:\jenkins\workspace\GitHub for Visual Studio speakeasy jenkinskeep\src\GitHub.Exports\Services\UsageTracker.cs:line 138
        at GitHub.Services.UsageTracker.IncrementLaunchCount() in Y:\jenkins\workspace\GitHub for Visual Studio speakeasy jenkinskeep\src\GitHub.Exports\Services\UsageTracker.cs:line 73
        at GitHub.VisualStudio.GitHubPackage.Initialize() in Y:\jenkins\workspace\GitHub for Visual Studio speakeasy jenkinskeep\src\GitHub.VisualStudio\GitHubPackage.cs:line 57
        at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)
     </description>

     <guid>{C3D3DC68-C977-411F-B3E8-03B0DCCF7DFC}</guid>
     <hr>8013150c</hr>
     <errorinfo></errorinfo>
   </entry>

@shana shana added the bug label Aug 23, 2016

shana added a commit that referenced this issue Aug 23, 2016

@shana shana modified the milestone: 2.0.14.5 Aug 26, 2016

@IanByun

This comment has been minimized.

Show comment
Hide comment
@IanByun

IanByun Sep 3, 2016

I am having this issue as well
Any way to solve this?

IanByun commented Sep 3, 2016

I am having this issue as well
Any way to solve this?

@shana shana closed this in #521 Sep 3, 2016

@shana shana reopened this Sep 3, 2016

@IanByun

This comment has been minimized.

Show comment
Hide comment
@IanByun

IanByun Sep 3, 2016

Getting "The 'GitHubPackage' package did not load correctly" error message on start-up
and getting "Invalid JSON string" when trying to login to GitHub via Team Explorer

IanByun commented Sep 3, 2016

Getting "The 'GitHubPackage' package did not load correctly" error message on start-up
and getting "Invalid JSON string" when trying to login to GitHub via Team Explorer

@shana

This comment has been minimized.

Show comment
Hide comment
@shana

shana Sep 3, 2016

Collaborator

@IanByun Oh, I'm sorry, seems like the fix didn't make it to the latest release! There'll be a new release on Monday with it, but in the meantime, close VS and delete %localappdata%\GitHubVisualStudio\ghfvs.usage, that should fix it.

Collaborator

shana commented Sep 3, 2016

@IanByun Oh, I'm sorry, seems like the fix didn't make it to the latest release! There'll be a new release on Monday with it, but in the meantime, close VS and delete %localappdata%\GitHubVisualStudio\ghfvs.usage, that should fix it.

@IanByun

This comment has been minimized.

Show comment
Hide comment
@IanByun

IanByun Sep 3, 2016

@shana Great! Your solution fixed my VS. Thanks

IanByun commented Sep 3, 2016

@shana Great! Your solution fixed my VS. Thanks

@shana

This comment has been minimized.

Show comment
Hide comment
@shana

shana Sep 3, 2016

Collaborator

FYI, I just pushed out a new release v2.0.15.1 with a fix for this, so if you're getting hit by it, be sure to update!

Collaborator

shana commented Sep 3, 2016

FYI, I just pushed out a new release v2.0.15.1 with a fix for this, so if you're getting hit by it, be sure to update!

@shana shana closed this Sep 3, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment