Permalink
Browse files

Actually give up on 1.8.7 compatbility

Gemoji implementation depends on `codepoints` and test depend on some
more Ruby 1.9-only features, so don't pretend that the library will be
1.8 compatible anytime soon. Probably never.

This reverts commit 6a781b6.
  • Loading branch information...
1 parent 6a781b6 commit 72aecc9105c0cde3763a1c9d23cb4fd8de241a4a @mislav mislav committed Jun 27, 2014
Showing with 2 additions and 4 deletions.
  1. +0 −1 .travis.yml
  2. +0 −1 Gemfile
  3. +0 −2 Gemfile.lock
  4. +2 −0 gemoji.gemspec
View
@@ -1,5 +1,4 @@
rvm:
- - 1.8.7
- 1.9.3
- 2.1.2
notifications:
View
@@ -2,6 +2,5 @@ source "https://rubygems.org"
gem "rake"
gem "minitest"
-gem "json", :platform => :mri_18
gemspec
View
@@ -6,7 +6,6 @@ PATH
GEM
remote: https://rubygems.org/
specs:
- json (1.8.1)
minitest (5.3.5)
rake (10.3.2)
@@ -15,6 +14,5 @@ PLATFORMS
DEPENDENCIES
gemoji!
- json
minitest
rake
View
@@ -4,6 +4,8 @@ Gem::Specification.new do |s|
s.summary = "Emoji Assets"
s.description = "Emoji assets"
+ s.required_ruby_version = '~> 1.9'
+
s.authors = ["GitHub"]
s.email = "support@github.com"
s.homepage = "https://github.com/github/gemoji"

0 comments on commit 72aecc9

Please sign in to comment.